Ask Your Question
0

Change default store to vsphere

asked 2015-02-18 15:01:03 -0500

wharfedale gravatar image

updated 2015-02-18 15:03:02 -0500

Hi,

I'm trying to build an openstack with vsphere backend myself, comparing with a working icehouse.vova.

When changing the default store in /etc/glance/glance-api.conf to vsphere

default_store = vsphere

and adding vmware options

known_stores = glance.store.vmware_datastore.Store, glance.store.filesystem.Store
vmware_server_host = 192.168.0.51
vmware_server_username = root
vmware_server_password = vmware
vmware_datacenter_path = Datacenter
vmware_datastore_name = "Crucial 240"

I get an error like this

root@controller:/var/lib/glance/images# glance --debug image-list
curl -i -X GET -H 'User-Agent: python-glanceclient' -H 'Content-Type: application/octet-stream' -H 'Accept-Encoding: gzip, deflate' -H 'Accept: */*' -H 'X-Auth-Token: ***' http://controller:9292/v1/images/detail?sort_key=name&sort_dir=asc&limit=20
Error finding address for http://controller:9292/v1/images/detail?sort_key=name&sort_dir=asc&limit=20: HTTPConnectionPool(host='controller', port=9292): Max retries exceeded with url: /v1/images/detail?sort_key=name&sort_dir=asc&limit=20 (Caused by <class 'socket.error'>: [Errno 111] Connection refused)

When changing back to default store = file, everything works.

I've looked at the config file on a working icehouse.vova, but couldn't see why this doesn't work.

I looks like to glance-api doesn't restart, /var/log/glance/glance-api.log doesnt show an error.

root@controller:/var/lib/glance/images# service glance-api restart
stop: Unknown instance: 
glance-api start/running, process 3654
root@controller:/var/lib/glance/images# service glance-api status
glance-api stop/waiting

Any idea's?

edit retag flag offensive close merge delete

Comments

Found the solution:

-There is a section with vmware options in glance-api.conf
-know_stores must be stores
wharfedale gravatar imagewharfedale ( 2015-02-19 04:03:45 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-02-18 17:17:10 -0500

You need to look at why glance-api doesnt start when you have the default_store = vsphere.

Add your vsphere options back in to glance-api.conf and then restart glance-api.

Then paste the logs from /var/log/glance/api.log.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-18 15:01:03 -0500

Seen: 343 times

Last updated: Feb 18 '15