Ask Your Question
0

devstack installation fails: 'Error: Service q-agt is not running'

asked 2015-02-18 09:54:26 -0500

Jim.Zhang gravatar image

Problem:

I am trying to install devstack in a vm, using juno release with neutron.

git clone https://github.com/openstack-dev/devstack.git (https://github.com/openstack-dev/devs...) -b stable/juno

Setup:

  • vmplayer
  • ubuntu 12.04.3
  • local.conf (couldn't attach file, need 10 points to do that?) (pasting just the relevent parts of local.conf here)

Branch

NEUTRON_BRANCH=stable/juno

# Neutron DISABLED_SERVICES=n-net ENABLED_SERVICES+=,q-svc,q-agt,q-dhcp,q-l3,q-meta,q-metering,neutron

VLAN configuration

Q_PLUGIN=ml2 ENABLE_TENANT_VLANS=True ML2_VLAN_RANGES=physnet1:100:199

Error message i get:

    2015-02-17 18:41:36.202 | + [[ ! -d /opt/stack/status/stack ]]
    2015-02-17 18:41:36.214 | ++ ls /opt/stack/status/stack/q-agt.failure /opt/stack/status/stack/q-dhcp.failure
    2015-02-17 18:41:36.253 | + failures='/opt/stack/status/stack/q-agt.failure
    2015-02-17 18:41:36.254 | /opt/stack/status/stack/q-dhcp.failure'
    2015-02-17 18:41:36.254 | + for service in '$failures'
    2015-02-17 18:41:36.255 | ++ basename /opt/stack/status/stack/q-agt.failure
    2015-02-17 18:41:36.275 | + service=q-agt.failure
    2015-02-17 18:41:36.275 | + service=q-agt
    2015-02-17 18:41:36.275 | + echo 'Error: Service q-agt is not running'
    2015-02-17 18:41:36.275 | Error: Service q-agt is not running
    2015-02-17 18:41:36.276 | + for service in '$failures'
    2015-02-17 18:41:36.277 | ++ basename /opt/stack/status/stack/q-dhcp.failure
    2015-02-17 18:41:36.279 | + service=q-dhcp.failure
    2015-02-17 18:41:36.280 | + service=q-dhcp
    2015-02-17 18:41:36.280 | + echo 'Error: Service q-dhcp is not running'
    2015-02-17 18:41:36.280 | Error: Service q-dhcp is not running
    2015-02-17 18:41:36.280 | + '[' -n '/opt/stack/status/stack/q-agt.failure
    2015-02-17 18:41:36.281 | /opt/stack/status/stack/q-dhcp.failure' ']'
    2015-02-17 18:41:36.281 | + die 1409 'More details about the above errors can be found with screen, with ./rejoin-stack.sh'
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-02-18 20:34:08 -0500

Looks like neither q-agt or q-dhcp are running. Can you run rejoin_stack.sh at that point? That should bring up a screen session with tabs related to all openstack services running.

Switch to the tab with name q-svc (ctrl-a-<num> to switch to tab #N, or ctrl-a-n to switch to the next tab)

The tabs for q-dhcp and q-agt should hopefully show something helpful. :)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-18 09:54:26 -0500

Seen: 1,977 times

Last updated: Feb 18 '15