Ask Your Question
0

openstack High Availability corosync API error 2

asked 2015-02-17 13:19:30 -0500

rp1393 gravatar image

updated 2015-02-17 13:23:14 -0500

hi

im trying to set up openstack HA on my controller node on a virtual machine, and my other node got ubuntu 14.10 on a physical machine

i have used this command on both nodes to get packages:

rp@pc:~$ sudo apt-get install pacemaker crmsh corosync cluster-glue resource-agents

no matter how i configure corosync.conf file, when i use the command sudo service corosync restart;sudo /etc/init.d/corosync restart;sudo corosync-cfgtool -s

i get the error of :

Printing ring status.
Could not initialize corosync configuration API error 2

corosync config file

openstack@controller:~$ cat /etc/corosync/corosync.conf
# Please read the openais.conf.5 manual page

totem {
    version: 2

    # How long before declaring a token lost (ms)
    token: 10000

    # How many token retransmits before forming a new configuration
    token_retransmits_before_loss_const: 10

    # How long to wait for join messages in the membership protocol (ms)
    #join: 60

    # How long to wait for consensus to be achieved before starting a new round of membership configuration (ms)
    #consensus: 3600

    # Turn off the virtual synchrony filter
    vsftype: none

    # Number of messages that may be sent by one processor on receipt of the token
    #max_messages: 20

    # Limit generated nodeids to 31-bits (positive signed integers)
    #clear_node_high_bit: yes

    # Disable encryption
    secauth: on

    # How many threads to use for encryption/decryption
    threads: 0

    # Optionally assign a fixed node id (integer)
    # nodeid: 1234

    # This specifies the mode of redundant ring, which may be none, active, or passive.
    rrp_mode: active

    interface {
        # The following values need to be set based on your environment 
        ringnumber: 0
        bindnetaddr: 192.168.1.11
        mcastaddr: 239.255.42.1
    mcastport: 5405
    }
interface {
        # The following values need to be set based on your environment 
        ringnumber: 1
        bindnetaddr: 192.168.1.2
        mcastaddr: 239.255.42.2
    mcastport: 5405
    }

}

amf {
    mode: disabled
}



aisexec {
        user:   root
        group:  root
}

logging {
        fileline: off
        to_stderr: yes
        to_logfile: no
        to_syslog: yes
    syslog_facility: daemon
        debug: off
        timestamp: on
        logger_subsys {
                subsys: AMF
                debug: off
                tags: enter|leave|trace1|trace2|trace3|trace4|trace6
        }
}
openstack@controller:~$

controller node :

root@controller:~# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 52:54:00:50:45:87  
          inet addr:192.168.1.11  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::5054:ff:fe50:4587/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1143 errors:0 dropped:17 overruns:0 frame:0
          TX packets:743 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:153598 (153.5 KB)  TX bytes:71377 (71.3 KB)

the other node:

rp@pc:~$  ifconfig br0
br0       Link encap:Ethernet  HWaddr 74:d4:35:e9:26:62  
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::76d4:35ff:fee9:2662/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:38893 errors:0 dropped:0 overruns:0 frame:0
          TX packets:33009 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes ...
(more)
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-02-17 18:30:29 -0500

SamYaple gravatar image

bindnetaddr should only have the network address. You should only have one interface entry per subnet.

    interface {
        # The following values need to be set based on your environment 
        ringnumber: 0
        bindnetaddr: 192.168.1.0
        mcastaddr: 239.255.42.1
        mcastport: 5405
    }
edit flag offensive delete link more

Comments

Hi, thanks for the reply. Still got the same error even by having only one interface as u mentioned.

rp1393 gravatar imagerp1393 ( 2015-02-18 03:33:07 -0500 )edit
0

answered 2015-03-13 04:28:53 -0500

Corosync is probably not running (any more) Check:

ps aux | grep corosync
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-17 13:19:30 -0500

Seen: 1,886 times

Last updated: Feb 17 '15