Ask Your Question
0

lb vip is in error status

asked 2015-02-17 06:43:06 -0500

anonymous user

Anonymous

updated 2015-02-18 00:48:46 -0500

Hi,

I am new to openstack and I have installed openstack by following juno released documentation on fedora 20

Install went fine but when I tried to configure lbaas agent then lb vip create commend didnt return any error but its status is error ad below is the command output root@controller etc]# neutron lb-vip-list +--------------------------------------+-------+---------------+----------+----------------+--------+ | id | name | address | protocol | admin_state_up | status | +--------------------------------------+-------+---------------+----------+----------------+--------+ | 9c453286-a95c-4796-844b-37c2f4a8ae6f | myvip | 10.130.98.240 | HTTP | True | ERROR |

Below is error log tail -f /var/log/neutron/lbaas-agent.log 2015-02-18 20:35:56.189 25230 TRACE neutron.services.loadbalancer.agent.agent_manager File "/usr/lib/python2.7/site-packages/neutron/agent/linux/ip_lib.py", line 550, in execute 2015-02-18 20:35:56.189 25230 TRACE neutron.services.loadbalancer.agent.agent_manager check_exit_code=check_exit_code, extra_ok_codes=extra_ok_codes) 2015-02-18 20:35:56.189 25230 TRACE neutron.services.loadbalancer.agent.agent_manager File "/usr/lib/python2.7/site-packages/neutron/agent/linux/utils.py", line 84, in execute 2015-02-18 20:35:56.189 25230 TRACE neutron.services.loadbalancer.agent.agent_manager raise RuntimeError(m) 2015-02-18 20:35:56.189 25230 TRACE neutron.services.loadbalancer.agent.agent_manager RuntimeError: 2015-02-18 20:35:56.189 25230 TRACE neutron.services.loadbalancer.agent.agent_manager Command: ['sudo', 'neutron-rootwrap', '/etc/neutron/rootwrap.conf', 'ip', 'netns', 'exec', 'qlbaas-01e58a7b-929a-4b65-90cc-e77f6fbd184c', 'haproxy', '-f', '/var/lib/neutron/lbaas/01e58a7b-929a-4b65-90cc-e77f6fbd184c/conf', '-p', '/var/lib/neutron/lbaas/01e58a7b-929a-4b65-90cc-e77f6fbd184c/pid'] 2015-02-18 20:35:56.189 25230 TRACE neutron.services.loadbalancer.agent.agent_manager Exit code: 1 2015-02-18 20:35:56.189 25230 TRACE neutron.services.loadbalancer.agent.agent_manager Stdout: '' 2015-02-18 20:35:56.189 25230 TRACE neutron.services.loadbalancer.agent.agent_manager Stderr: "[ALERT] 048/203556 (25634) : parsing [/var/lib/neutron/lbaas/01e58a7b-929a-4b65-90cc-e77f6fbd184c/conf:4] : cannot find group id for 'nogroup' (0:Success)\n[ALERT] 048/203556 (25634) : Error(s) found in configuration file : /var/lib/neutron/lbaas/01e58a7b-929a-4b65-90cc-e77f6fbd184c/conf\n[ALERT] 048/203556 (25634) : Fatal errors found in configuration.\n" 2015-02-18 02:54:18.396 5510 WARNING neutron.services.loadbalancer.drivers.haproxy.namespace_driver [-] Stats socket not found for pool 2eec2ed8-4aca-4e43-a64b-41508e78da3c

It will be really heplful if someone can provide a proper lbass installation and validation document or please provide some check point for this issue to resolve .

Below is lbass configuration detail configured using admin credential neutron lb-pool-create --lb-method ROUND_ROBIN --name mypool --protocol HTTP --subnet-id demo-subnet neutron lb-member-create --address 192.168.1.7 --protocol-port 80 mypool neutron lb-member-create --address 192.168.1.8 --protocol-port 80 mypool neutron lb-healthmonitor-create --delay 3 --type HTTP --max-retries 3 --timeout 3 neutron lb-healthmonitor-associate 5dee0fba-050a-440c-9625-52a06700719f mypool neutron lb-vip-create --name myvip --protocol-port 80 --protocol HTTP --subnet-id ext-subnet mypool

I observed that user_gourp id is not found while creating VIP from the lbaas-agent.log file

Thanks & Regards, ds_30

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-02-24 05:11:51 -0500

vs38 gravatar image

updated 2015-02-24 05:12:46 -0500

try user_group = haproxy in /etc/neutron/lbaas_agent.ini it worked for me

thanks shankar.

edit flag offensive delete link more

Comments

I tired the same user_group=haproxy and It worked in my setup as well .

Thanks, Deepa

deepa gravatar imagedeepa ( 2015-02-24 23:17:52 -0500 )edit
1

answered 2015-02-18 16:34:54 -0500

David O gravatar image

Once the VIP is established, the corresponding haproxy process is started. If you don't update the /etc/neutron/lbaas_agent.ini file to not a specific group, it will default to group "nogroup". Either uncomment the directive and select haproxy for the group or configure a group "nogroup". That should fix your problem.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-02-17 06:43:06 -0500

Seen: 1,529 times

Last updated: Feb 24 '15