Ask Your Question
0

devstack: All-In-One Single Machine with two compute nodes

asked 2015-02-17 05:36:10 -0500

AlonFre gravatar image

Hi all,

we want to install devstack in "All-In-One Single Machine" with two compute nodes inorder to simulate instance migration between two compute nodes. we followd by this All-In-One Single Machine guide and the machine is up and running. our question is, how to add another virtual compute node on this machine? is there any guide for a sutup like this?

Thanks in advance, Alon.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-02-18 15:37:55 -0500

Devstack as-is won't really do that on a single machine without lots of munging. Take a look at this doc:

http://docs.openstack.org/developer/devstack/guides/multinode-lab.html (http://docs.openstack.org/developer/d...)

You can set Devstack up to be a compute node or a head node... but it can't do multiple instances of itself on the same machine without an extra virt layer. I guess you could install kvm.. spin up a couple nodes.. and then install devstack instance on each (sorta like openstack-on-openstack, or the tripleo virt mode).

edit flag offensive delete link more
0

answered 2016-04-11 12:15:12 -0500

rizkimounir gravatar image

hello! i want use openstack with devstack multinode, i use two hosts : 10.3.21.201 with localrc :**/

HOST_IP=10.3.21.201 FLAT_INTERFACE=eth0 FIXED_RANGE=10.3.20.0/23 FLOATING_RANGE=192.168.42.128/25 MULTI_HOST=1 LOGFILE=/opt/stack/logs/stack.sh.log ADMIN_PASSWORD=test DATABASE_PASSWORD=test RABBIT_PASSWORD=test SERVICE_PASSWORD=test and 10.3.20.166 with localrc HOST_IP=10.3.21.166 FLAT_INTERFACE=eth0 FIXED_RANGE=10.3.20.0/23 FLOATING_RANGE=192.168.42.128/25 MULTI_HOST=1 LOGFILE=/opt/stack/logs/stack.sh.log ADMIN_PASSWORD=test DATABASE_PASSWORD=test RABBIT_PASSWORD=test SERVICE_PASSWORD=test DATABASE_TYPE=mysql SERVICE_HOST=10.3.21.201 MYSQL_HOST=$SERVICE_HOST RABBIT_HOST=$SERVICE_HOST GLANCE_HOSTPORT=$SERVICE_HOST:9292 ENABLED_SERVICES=n-cpu,n-net,n-api-meta,c-vol NOVA_VNC_ENABLED=True NOVNCPROXY_URL="http://$SERVICE_HOST:6080/vnc_auto.html" VNCSERVER_LISTEN=$HOST_IP VNCSERVER_PROXYCLIENT_ADDRESS=$VNCSERVER_LISTEN

the problem when i use nova hypervisor-list i hav just the service host (10.3.20.201) thanks

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-17 05:36:10 -0500

Seen: 822 times

Last updated: Apr 11 '16