Error when building python-swiftclient

asked 2013-10-18 08:05:39 -0600

rahmu gravatar image

updated 2013-10-18 08:24:58 -0600

Here are the exact steps I'm following on my Mac OS X laptop:

$ git clone http://github.com/openstack/python-swiftclient.git

$ virtualenv ~/.venv/swiftclient2
$ source ~/.venv/swiftclient2/bin/activate

$ cd python-swiftclient
$ python setup.py develop

And I get this error:

/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'dist'
  warnings.warn(msg)
running develop
running egg_info
writing requirements to python_swiftclient.egg-info/requires.txt
writing python_swiftclient.egg-info/PKG-INFO
writing top-level names to python_swiftclient.egg-info/top_level.txt
writing dependency_links to python_swiftclient.egg-info/dependency_links.txt
[pbr] Reusing existing SOURCES.txt
running build_ext
Creating /Users/joehakimrahme/.venv/swiftclient2/lib/python2.7/site-packages/python-swiftclient.egg-link (link to .)
python-swiftclient 1.8.0.1.ge08ec3a is already the active version in easy-install.pth
Installing swift script to /Users/joehakimrahme/.venv/swiftclient2/bin

Installed /Users/joehakimrahme/VagrantVM/devstack/python-swiftclient
Processing dependencies for python-swiftclient==1.8.0.1.ge08ec3a
Searching for simplejson>=2.0.9
Reading http://pypi.python.org/simple/simplejson/
Best match: simplejson 3.3.1
Downloading https://pypi.python.org/packages/source/s/simplejson/simplejson-3.3.1.tar.gz#md5=36eec59b63bb852eaaac724ac8985f74
Processing simplejson-3.3.1.tar.gz
Running simplejson-3.3.1/setup.py -q bdist_egg --dist-dir /var/folders/td/6j5vqfc17msdrb0bd0jmldqm0000gn/T/easy_install-Mkjkg2/simplejson-3.3.1/egg-dist-tmp-x4Nkdo
Traceback (most recent call last):
  File "setup.py", line 23, in <module>
    pbr=True)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/core.py", line 152, in setup
    dist.run_commands()
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/dist.py", line 953, in run_commands
    self.run_command(cmd)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/dist.py", line 972, in run_command
    cmd_obj.run()
  File "/Users/joehakimrahme/.venv/swiftclient2/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/setuptools/command/develop.py", line 27, in run
  File "/Users/joehakimrahme/.venv/swiftclient2/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/setuptools/command/develop.py", line 102, in install_for_development
  File "/Users/joehakimrahme/.venv/swiftclient2/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/setuptools/command/easy_install.py", line 519, in process_distribution
  File "/Users/joehakimrahme/.venv/swiftclient2/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/pkg_resources.py", line 563, in resolve
  File "/Users/joehakimrahme/.venv/swiftclient2/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/pkg_resources.py", line 799, in best_match
  File "/Users/joehakimrahme/.venv/swiftclient2/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/pkg_resources.py", line 811, in obtain
  File "/Users/joehakimrahme/.venv/swiftclient2/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/setuptools/command/easy_install.py", line 446, in easy_install
  File "/Users/joehakimrahme/.venv/swiftclient2/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/setuptools/command/easy_install.py", line 476, in install_item
  File "/Users/joehakimrahme/.venv/swiftclient2/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/setuptools/command/easy_install.py", line 655, in install_eggs
  File "/Users/joehakimrahme/.venv/swiftclient2/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/setuptools/command/easy_install.py", line 930, in build_and_install
  File "/Users/joehakimrahme/.venv/swiftclient2/lib ...
(more)
edit retag flag offensive close merge delete

Comments

1

is it working for you now?

koolhead17 gravatar imagekoolhead17 ( 2014-01-02 00:45:03 -0600 )edit

Yes this bug has disappeared when I try to install a recent version of HEAD.

rahmu gravatar imagerahmu ( 2014-01-27 09:42:37 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2013-10-25 17:25:34 -0600

smaffulli gravatar image

Checkout this bug report, I believe it's an issue with your version of setuptools: https://bugs.launchpad.net/swift/+bug/1217288

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-10-18 08:05:39 -0600

Seen: 488 times

Last updated: Oct 25 '13