Ask Your Question
0

503 Internal Server Error

asked 2015-02-16 03:21:33 -0500

koryk gravatar image

updated 2015-02-16 03:27:55 -0500

Hello expert,

I have problems with "swift stat" command and I wonder if anyone can assist me in troubleshooting the issue.

I 've got the error "INFO:swiftclient:RESP STATUS: 503 Internal Server Error" when run the command "Swift stat" with debug options. I understand there are several similar cases already addressed in this site, however, it really did not help to resolve my problem.

Here are my finding so far.

  • there is a case with the same error/same command but error is slightly different with mine..the error I am facing does include only single 8080 not double such as 8080/8080.

  • I have tried to change the bind_ip on storage nodes in every account/object/container conf files to "0.0.0.0" but stills same issue.

  • From controller node, when doing swing-ring-builder command for account/object/container, it passes okay with no problems.

  • systemctl status on all the services from controller node/storage nodes look perfectly okay. No failures found. (I checked "proxy-server, memcache on controller and account/container/object services on storage nodes")

  • Have tried to delete endpoint from keystone and recreate it but did not help.

  • Have attempted to use new proxy-server.conf file but did not fix it either.

############ The errors I am getting when running swift --debug stat. ##########

@controller /]$ swift --debug stat DEBUG:keystoneclient.auth.identity.v2:Making authentication request to http://controller:5000/v2.0/tokens INFO:urllib3.connectionpool:Starting new HTTP connection (1): controller DEBUG:urllib3.connectionpool:"POST /v2.0/tokens HTTP/1.1" 200 3519 DEBUG:iso8601.iso8601:Parsed 2015-02-16T10:09:45Z into {'tz_sign': None, 'second_fraction': None, 'hour': u'10', 'daydash': u'16', 'tz_hour': None, 'month': None, 'timezone': u'Z', 'second': u'45', 'tz_minute': None, 'year': u'2015', 'separator': u'T', 'monthdash': u'02', 'day': None, 'minute': u'09'} with default timezone DEBUG:iso8601.iso8601:Got u'2015' for 'year' with default None DEBUG:iso8601.iso8601:Got u'02' for 'monthdash' with default 1 DEBUG:iso8601.iso8601:Got 2 for 'month' with default 2 DEBUG:iso8601.iso8601:Got u'16' for 'daydash' with default 1 DEBUG:iso8601.iso8601:Got 16 for 'day' with default 16 DEBUG:iso8601.iso8601:Got u'10' for 'hour' with default None DEBUG:iso8601.iso8601:Got u'09' for 'minute' with default None DEBUG:iso8601.iso8601:Got u'45' for 'second' with default None INFO:urllib3.connectionpool:Starting new HTTP connection (1): controller

DEBUG:urllib3.connectionpool:"HEAD /v1/AUTH_eb479d640e874c4ab0131f1f8c31efba HTTP/1.1" 503 0 INFO:swiftclient:REQ: curl -i http://controller:8080/v1/AUTH_eb479d640e874c4ab0131f1f8c31efba (http://controller:8080/v1/AUTH_eb479d...) -I -H "X-Auth-Token: ed4e8cbf6ced46f9b1e643a6513ef383" INFO:swiftclient:RESP STATUS: 503 Internal Server Error

INFO:swiftclient:RESP HEADERS: [('date', 'Mon, 16 Feb 2015 09:09:46 GMT'), ('content-length', '0'), ('content-type', 'text/html; charset=UTF-8'), ('x-trans-id', 'txe9101653babb4e57ace58-0054e1b3d9')] DEBUG:urllib3.connectionpool:"HEAD /v1/AUTH_eb479d640e874c4ab0131f1f8c31efba HTTP/1.1" 503 0 INFO:swiftclient:REQ: curl -i http://controller:8080/v1/AUTH_eb479d640e874c4ab0131f1f8c31efba (http://controller:8080/v1/AUTH_eb479d...) -I -H "X-Auth-Token: ed4e8cbf6ced46f9b1e643a6513ef383" INFO:swiftclient:RESP STATUS: 503 Internal Server Error INFO:swiftclient:RESP HEADERS ... (more)

edit retag flag offensive close merge delete

Comments

Have you ensured the various swift services: openstack-swift-proxy,openstack-swift-account,openstac-swift-container,openstack-swift-object are active..!! and then run "swift stat -v"

Praveen N gravatar imagePraveen N ( 2015-02-16 05:21:48 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-02-22 04:44:05 -0500

koryk gravatar image

I verified everything working fine. I even checked every swift related services on controller node and storage nodes and they were running all okay with no single error.

I found firewall is running on centOS 7, and since I disabled it (I just did systemctl stop/disable firewalld.service) and swift stat/list commands perfectly working with no problems.

No 503 errors either.

edit flag offensive delete link more

Comments

Can you enable the firewall and dump the rules ? It might help to document about this. Thanks

Hugo Kuo gravatar imageHugo Kuo ( 2015-02-24 03:52:04 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-16 03:21:33 -0500

Seen: 779 times

Last updated: Feb 22 '15