Ask Your Question
0

Neutron Error: Unable to create tunnel port. Invalid remote IP: INSTANCE_TUNNELS_INTERFACE_IP_ADDRESS [closed]

asked 2015-02-15 03:15:20 -0500

songco gravatar image

In my openstack environment's compute node, when I setup this node, I forget to update ml2_conf.ini so it prompt errors in /var/log/neutron/openvswitch-agent.log:

2015-02-15 00:35:06.847 1798 WARNING neutron.plugins.openvswitch.agent.ovs_neutron_agent [-] Unable to create tunnel port. Invalid remote IP
: INSTANCE_TUNNELS_INTERFACE_IP_ADDRESS

So I update local_ip in ml2_conf.ini file, and then restart the agent service, but the error still exist. I don't know why the agent/plugin still using the old config value. I also checked db table neotron.agents, and use "ovs_vsctl show" both output are ok(show correct ip address).

however, each time I restart agent service, there's one more log in /etc/openvswitch/conf.db:

/etc/openvswitch/conf.db:{"_date":1423986272061,"Port":{"df3cba43-b427-443f-84c5-93f7b8bdd3ff":{"name":"gre-c0a80317","interfaces":["uuid","
9ae642ec-9281-4bc4-bbda-884d9369b1cf"]}},"Bridge":{"16fccda6-1a5c-4468-9c14-67eadf38cc57":{"ports":["set",[["uuid","229a6b5f-e9fa-45fe-b5e7-
c2f041ead8e5"],["uuid","5442202a-2f0b-4977-a5cd-e484c0161694"],["uuid","df3cba43-b427-443f-84c5-93f7b8bdd3ff"]]]}},"Interface":{"9ae642ec-92
81-4bc4-bbda-884d9369b1cf":{"options":["map",[["in_key","flow"],["local_ip","INSTANCE_TUNNELS_INTERFACE_IP_ADDRESS"],["out_key","flow"],["re
mote_ip","192.168.3.23"]]],"name":"gre-c0a80317","type":"gre"}},"_comment":"ovs-vsctl: /usr/bin/ovs-vsctl --timeout=10 -- --may-exist add-po
rt br-tun gre-c0a80317 -- set Interface gre-c0a80317 type=gre options:remote_ip=192.168.3.23 options:local_ip=INSTANCE_TUNNELS_INTERFACE_IP_
ADDRESS options:in_key=flow options:out_key=flow","Open_vSwitch":{"b0e8494b-5893-487f-863c-9538ec626bee":{"next_cfg":23}}}

The local_ip is the wrong one.

my environment:

os: Linux compute 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:11:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
neutron-plugin-openvswitch-agent: Installed: 1:2014.1.3-0ubuntu1.1
neutron-plugin-ml2: Installed: 1:2014.1.3-0ubuntu1.1

any one help on this issue?

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by songco
close date 2015-02-16 00:21:32.516281

1 answer

Sort by ยป oldest newest most voted
2

answered 2015-02-15 03:25:50 -0500

songco gravatar image

I tried to restart neutron service(on compute and network node) and restart compute/network operation system, it doesn't help.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-15 03:15:20 -0500

Seen: 212 times

Last updated: Feb 15 '15