Ask Your Question
0

Neutron Error: Unable to create tunnel port. Invalid remote IP: INSTANCE_TUNNELS_INTERFACE_IP_ADDRESS

asked 2015-02-15 03:14:04 -0600

songco gravatar image

In my openstack environment's compute node, when I setup this node, I forget to update ml2_conf.ini so it prompt errors in /var/log/neutron/openvswitch-agent.log:

2015-02-15 00:35:06.847 1798 WARNING neutron.plugins.openvswitch.agent.ovs_neutron_agent [-] Unable to create tunnel port. Invalid remote IP
: INSTANCE_TUNNELS_INTERFACE_IP_ADDRESS

So I update local_ip in ml2_conf.ini file, and then restart the agent service, but the error still exist. I don't know why the agent/plugin still using the old config value. I also checked db table neotron.agents, and use "ovs_vsctl show" both output are ok(show correct ip address).

however, each time I restart agent service, there's one more log in /etc/openvswitch/conf.db:

/etc/openvswitch/conf.db:{"_date":1423986272061,"Port":{"df3cba43-b427-443f-84c5-93f7b8bdd3ff":{"name":"gre-c0a80317","interfaces":["uuid","
9ae642ec-9281-4bc4-bbda-884d9369b1cf"]}},"Bridge":{"16fccda6-1a5c-4468-9c14-67eadf38cc57":{"ports":["set",[["uuid","229a6b5f-e9fa-45fe-b5e7-
c2f041ead8e5"],["uuid","5442202a-2f0b-4977-a5cd-e484c0161694"],["uuid","df3cba43-b427-443f-84c5-93f7b8bdd3ff"]]]}},"Interface":{"9ae642ec-92
81-4bc4-bbda-884d9369b1cf":{"options":["map",[["in_key","flow"],["local_ip","INSTANCE_TUNNELS_INTERFACE_IP_ADDRESS"],["out_key","flow"],["re
mote_ip","192.168.3.23"]]],"name":"gre-c0a80317","type":"gre"}},"_comment":"ovs-vsctl: /usr/bin/ovs-vsctl --timeout=10 -- --may-exist add-po
rt br-tun gre-c0a80317 -- set Interface gre-c0a80317 type=gre options:remote_ip=192.168.3.23 options:local_ip=INSTANCE_TUNNELS_INTERFACE_IP_
ADDRESS options:in_key=flow options:out_key=flow","Open_vSwitch":{"b0e8494b-5893-487f-863c-9538ec626bee":{"next_cfg":23}}}

The local_ip is the wrong one.

my environment:

os: Linux compute 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:11:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
neutron-plugin-openvswitch-agent: Installed: 1:2014.1.3-0ubuntu1.1
neutron-plugin-ml2: Installed: 1:2014.1.3-0ubuntu1.1

any one help on this issue?

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
2

answered 2015-02-27 20:32:33 -0600

songco gravatar image

This error message caused by invalid record in Controller's neutron database, after I delete the record of INSTANCE_TUNNELS_INTERFACE_IP_ADDRESS, the exception disappear.

edit flag offensive delete link more

Comments

Yes! That was it. MariaDB [neutron]> delete from ml2_gre_endpoints where ip_address='controller1';

I had a hostname instead of an IP, but it looks like the same error.

Darby gravatar imageDarby ( 2015-03-29 20:17:08 -0600 )edit
0

answered 2015-02-15 04:43:02 -0600

Moe gravatar image

you have to edit /etc/neutron/plugins/ml2/ml2_conf.ini at the end of file in [ovs] section change the INSTANCE_TUNNELS_INTERFACE_IP_ADDRESS with your IP address then try:

service openvswitch-switch restart
service neutron-plugin-openvswitch-agent restart
service nova-compute restart

I wish this helps :)

edit flag offensive delete link more

Comments

Thanks, I have tried this and it not work, currently, INSTANCE_TUNNELS_INTERFACE_IP_ADDRESS only appeared in log files and /etc/openvswitch/conf.db.

songco gravatar imagesongco ( 2015-02-15 19:28:58 -0600 )edit
0

answered 2015-05-03 23:24:15 -0600

swati-shukla1 gravatar image

Hi, did anyone get the answer to this one?

Pls help asap, facing this problem only.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-15 03:14:04 -0600

Seen: 2,383 times

Last updated: May 03 '15