Attempt to reproduce "Installing nova-docker with devstack" per Larsks

asked 2015-02-14 09:10:42 -0600

dbaxps gravatar image

updated 2015-03-07 10:55:19 -0600

UPDATE: As of 03/07/2015 . View What is missing commit 9d06520645f28d96ef905a709f8ff0c27842b58b in nova-docker master branch ?

UPDATE : As of 03/06/2015 Commit disables floating IPs for upstream NovaDocker Driver
is 9d06520645f28d96ef905a709f8ff0c27842b58b

I did procedure as described bellow for two next commits in master branch.
8760c73423dce9a47a6a67b32da016edd85cde86  keeps network working
9d06520645f28d96ef905a709f8ff0c27842b58b  crash network ( floating ips) for nova-docker containers

Each time new VM Ubuntu 14.04.2 has been created and installation procedure for docker , cloning
git clone , checkout of particular commit , patching required
*.py files for oslo logging , sudo pip install . has been run from scratch.

UPDATE : As of 03/05/2015 For now answer is as follows

$ git clone
$ cd nova-docker
$ git checkout  a1e3e3e2d1032649397fb8281de7c7360ce0ad31 ("Fix build breaks by using instance.flavor where appropriate")  
Apply as patch Commit "Sync oslo imports to be in line with Nova trunk" 333656f4ad0e2c06f11eb8244bd6796110b9931d
$ sudo pip install .

Now NovaDocker Driver is installed as of a time of writing
and switched to oslo logging via applying patch "Sync oslo imports to be in line with Nova trunk"
Hence, to be able to be loaded via Devstack (e.g. by the most recent status of Nova-compute.
When completes you would have floating IPs working and mentioned blog entry by Larsks still working.
The rest to be tested :-

commit 9d06520645f28d96ef905a709f8ff0c27842b58b
commit 8760c73423dce9a47a6a67b32da016edd85cde86

UPDATE : As of 03/03/2015. Please, view the most recent status of issue here :-

UPDATE : As of 02/22/2015 procedure described at
         may be performed, but created Nova-Docker driver is no longer functional.
         Neither floating IP, nor private IP any longer work. Nova boot just load container.
UPDATE : As of 02/24/2015 follow word in word same blog entry doing fresh installation (new VM) fails:
+ service=n-cpu.failure
2015-02-24 10:07:05.567 | + service=n-cpu
2015-02-24 10:07:05.568 | + echo 'Error: Service n-cpu is not running'
2015-02-24 10:07:05.568 | Error: Service n-cpu is not running
2015-02-24 10:07:05.569 | + '[' -n /home/ubuntu/stack/status/stack/n-cpu.failure ']'

Here is n-cpu screen log

    UPDATE : as of 02/25/2015 I compared three devstack installs <br>
        First  as of 02/15/2015
        Second as of 02/22/2015
        Third  as of 02/24/2015
        Third install generates file /home/ubuntu/stack/nova/openstack-common.conf
        without entry "module=log"
and this openstack-common.conf works for installing libvirt driver ( I had no doubt, even before tested)

Ubuntu 14.04 installed on VM (on KVM Hypervisor) with 2 VCPUS and 4 GB RAM. Everything what was promissed in works. What is my concern :-

3 nova-docker containers tested OK.
1. test0 ( from Larsks)
2. Ubuntu Rastasheep (sshd)
3. tutum/tomcat

I have noticed that br-ex had IP 172.24.4.X and eth0 has not become OVS port ...

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted

answered 2015-02-17 04:25:25 -0600

dbaxps gravatar image

updated 2015-03-06 12:09:31 -0600

UPDATE: as of 03/06/2015
Install working NovaDocker driver (network alive, e.g. floating IPs are working) on Ubuntu 14.04.2 via ./

$ git clone
$ cd nova-docker
$ git revert 9d06520645f28d96ef905a709f8ff0c27842b58b
$ sudo pip install .

Then follow Larsks blog entry

This is answer for question - " I also noticed that after reboot done as described above br-ex wich had IP comes up no IP at all."

1. cd devstack ; sudo ./
2. reboot
3. System comes up with br-ex having no IP , running ./ doesn't make much sense
    sudo ip addr flush dev br-ex
    sudo ip addr add dev br-ex
    sudo ip link set br-ex up
    sudo route add -net gw
4 cd devstack ; ./

System has been brought to working shape all nova-docker containers been launched before reboot
keep their floating IPs may be started and function as expected. New ones may be created assigned floating
IPs and started with normal behavior

edit flag offensive delete link more

answered 2015-02-14 09:30:33 -0600

larsks gravatar image

updated 2015-02-14 14:29:09 -0600

I'm not entirely clear what you're asking here. It's true that I did not bother setting up full external connectivity in that article; I was mostly focused on getting nova-docker up and running; the network setup is identical to a standard nova environment, which is well documented elsewhere.

I generally avoid automatically bridging the only interface on a single-interface system to br-ex, and instead rely on NAT rules to provide external connectivity to my OpenStack environment. In anything other than a dev/test environment, you would want a dedicated NIC for external connectivity (and setting up the bridge would not interrupt connectivity for your host).

If you opt to go this route, you can assign br-ex the ip address of the gateway for your external network (e.g.,, and then add a masquerade rule on your host:

iptables -t nat -A POSTROUTING -s -j MASQUERADE

This will permit instances in your OpenStack environment to have outbound connectivity, and you will have access to your instances from your host. This will not permit inbound connectivity to your instances from anywhere other than your host, of course.

Otherwise, if you want to bridge a physical interface to br-ex to provide true inbound connectivity, you would need to choose a floating ip range that was compatible with your local network environment.

If you are briding a real physical interface to br-ex, you can't set FLOATING_RANGE to a random value; it needs to match whatever address range is appropriate for your local subnet (so, only you know what this should be). You will also need to ensure that PUBLIC_NETWORK_GATEWAY is an address on the FLOATING_RANGE network. If PUBLIC_NETWORK_GATEWAY is not reachable from the router namespaces, you will see errors from Neutron when it attempts to set up the default route for the router namespace.

edit flag offensive delete link more


That is what I am asking about . I tried add FLOATING_RANGE= per
but crashed configuring Neutron due to bad allocation pool. I don't know correct syntax of local.conf update

dbaxps gravatar imagedbaxps ( 2015-02-14 10:33:46 -0600 )edit

I've updated my answer with some notes about FLOATING_RANGE; let me know if that helps.

larsks gravatar imagelarsks ( 2015-02-14 14:29:32 -0600 )edit

Today (02/15) fails with or without updates ( even original from your post )

+ service=n-cpu.failure
+ service=n-cpu
+ echo 'Error: Service n-cpu is not running'
Error: Service n-cpu is not running
+ '[' -n /opt/stack/status/stack/n-cpu.failure ']'
dbaxps gravatar imagedbaxps ( 2015-02-15 03:08:10 -0600 )edit

I attempted update local.conf , but with no luck.

dbaxps gravatar imagedbaxps ( 2015-02-15 03:09:38 -0600 )edit

Correct syntax may be found here :
It doesn't generate mistake above

dbaxps gravatar imagedbaxps ( 2015-02-16 00:27:28 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2015-02-14 09:10:42 -0600

Seen: 1,035 times

Last updated: Mar 07 '15