Ask Your Question
0

Not able to start swift proxy server.

asked 2015-02-13 19:59:52 -0500

koryk gravatar image

Hello expert.

I am having problems starting up swift proxy server on controller node. Can you please have a look at the logs and let me know what can be done? I have been following the link http://docs.openstack.org/juno/install-guide/install/yum/content/swift-install-controller-node.html (http://docs.openstack.org/juno/instal...) for the configurations however, I am still not able to really start it up despite of multiple confirmations of proxy-server.conf file.

[root@controller swift]# id uid=0(root) gid=0(root) groups=0(root) context=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 [root@controller swift]# [root@controller swift]# [root@controller swift]# uname -a Linux controller 3.10.0-123.20.1.el7.x86_64 #1 SMP Thu Jan 29 18:05:33 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux [root@controller swift]# [root@controller swift]# [root@controller swift]# systemctl start openstack-swift-proxy.service [root@controller swift]# [root@controller swift]# systemctl status openstack-swift-proxy.service openstack-swift-proxy.service - OpenStack Object Storage (swift) - Proxy Server Loaded: loaded (/usr/lib/systemd/system/openstack-swift-proxy.service; enabled) Active: failed (Result: exit-code) since Fri 2015-02-13 17:53:02 PST; 7s ago Process: 7452 ExecStart=/usr/bin/swift-proxy-server /etc/swift/proxy-server.conf (code=exited, status=1/FAILURE) Main PID: 7452 (code=exited, status=1/FAILURE)

Feb 13 17:53:02 controller swift-proxy-server[7452]: for name in pipeline[:-1]] Feb 13 17:53:02 controller swift-proxy-server[7452]: File "/usr/lib/python2.7/site-packages/swift/common/wsgi.py", line 61, in get_context Feb 13 17:53:02 controller swift-proxy-server[7452]: object_type, name=name, global_conf=global_conf) Feb 13 17:53:02 controller swift-proxy-server[7452]: File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 458, in get_context Feb 13 17:53:02 controller swift-proxy-server[7452]: section) Feb 13 17:53:02 controller swift-proxy-server[7452]: File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 514, in _context_from_explicit Feb 13 17:53:02 controller swift-proxy-server[7452]: "No loader given in section %r" % section) Feb 13 17:53:02 controller swift-proxy-server[7452]: LookupError: No loader given in section 'filter:cache' Feb 13 17:53:02 controller systemd[1]: openstack-swift-proxy.service: main process exited, code=exited, status=1/FAILURE Feb 13 17:53:02 controller systemd[1]: Unit openstack-swift-proxy.service entered failed state.

The last conf file I tried is as followings. [root@controller swift]# cat proxy-server.conf [DEFAULT] bind_port=8080 user=swift swift_dir=/etc/swift

[pipeline:main] pipeline=authtoken cache healthcheck keystoneauth proxy-logging proxy-server

[app:proxy-server] use=egg:swift#proxy allow_account_management=true account_autocreate=true

[filter:keystoneauth] use=egg:swift#keystoneauth #operator_roles=admin,_member_

[filter:authtoken] paste.filter_factory=keystonemiddleware.auth_token:filter_factory auth_uri=http://controller:5000/v2.0 identity_uri=http://controller:35357 admin_tenant_name=service admin_user=swift admin_password=SWIFT_PASS delay_auth_decision=true

[filter:cache] memcache_servers=127.0.0.1:11211

edit retag flag offensive close merge delete

5 answers

Sort by ยป oldest newest most voted
0

answered 2015-02-14 19:53:27 -0500

koryk gravatar image

Thanks Varsha and sfcloudman ..really appreciate your comments on it.

I have followed them up but I am still having the problems... Looking at /var/log/messages file, I see following errors...and it does not seem to be parameter related I guess.. Googling it, it seems to be bug, which I am still not quite sure about....I have tried to re-install the controller from scratch again however still having the same issue... I am using cents 7 now, maybe I need to try lower version of it..

Anyways, thanks for your help again. :) please provide any advise if you suspect anything else from below logs,

Feb 14 17:46:26 controller systemd: Starting OpenStack Object Storage (swift) - Proxy Server... Feb 14 17:46:26 controller systemd: Started OpenStack Object Storage (swift) - Proxy Server. Feb 14 17:46:26 controller python: detected unhandled Python exception in '/usr/bin/swift-proxy-server' Feb 14 17:46:26 controller swift-proxy-server: error: cannot open Packages database in /var/lib/rpm Feb 14 17:46:26 controller swift-proxy-server: Traceback (most recent call last): Feb 14 17:46:26 controller swift-proxy-server: File "/usr/bin/swift-proxy-server", line 23, in <module>

edit flag offensive delete link more

Comments

Please provide more details about your swift setup like how many storage nodes you are using? is the installation and configuration of the storage nodes done? are you able to create rings and rebalance it? what is the error displayed on terminal? installation steps completed etc.....

Varsha gravatar imageVarsha ( 2015-02-15 09:19:25 -0500 )edit

Hi, I have configured storage node with no issues and verified everything working fine. I was also able to create the rings and rebalance it fine. since then, I did "systemctl start openstack-swift-proxy.service memcached.service" followed by "swift stat" and found the command "swift stat" failing

koryk gravatar imagekoryk ( 2015-02-15 15:02:08 -0500 )edit

after that, I noticed proxy-server did not start successfully, which is the reason of why I am investigating it... I tried to correct the config file as advise however, it's not still statable yet..

koryk gravatar imagekoryk ( 2015-02-15 15:06:52 -0500 )edit

The errors in status says "swift-proxy-server[8694]: Error trying to load config from /etc/swift/proxy-server.conf: No loader given in section 'app...-server'

koryk gravatar imagekoryk ( 2015-02-15 15:08:39 -0500 )edit

I fixed the problem by re-installing openstack-swift-proxy package!!. Thanks guys all!!.

koryk gravatar imagekoryk ( 2015-02-15 23:43:35 -0500 )edit
0

answered 2015-02-13 23:32:58 -0500

Under [filter:cache] you are missing use = egg:swift

Add that right before the memache_servers directive.

edit flag offensive delete link more
0

answered 2015-02-14 08:46:17 -0500

Hi,

[app:proxy-server]...
allow_account_management = true
account_autocreate = true

Comment out any auth_host, auth_port, and auth_protocol options. Also recheck controller and password in [filter:authtoken] section.

edit flag offensive delete link more
0

answered 2015-02-15 02:53:55 -0500

1-Cloud gravatar image

updated 2015-02-15 02:57:52 -0500

Hi, here you did wrong configuration

Below is the correct session.

[app:proxy-server] ...

allow_account_management = true

account_autocreate = true

Then,

[filter:keystoneauth]

use = egg:swift#keystoneauth ...

operator_roles = admin,_member_

Now restart all services.

edit flag offensive delete link more
0

answered 2015-06-03 23:38:17 -0500

Mohib gravatar image

Hi I am facing same problem on opensuse 13.2 but after reinstall openstack-swift-proxy package not slove my problem. please help

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-13 19:59:52 -0500

Seen: 2,866 times

Last updated: Jun 03 '15