Ask Your Question
0

glance installation error [closed]

asked 2015-02-13 02:09:37 -0500

discophile gravatar image

updated 2015-02-15 19:13:16 -0500

Hi, I met an error when installing icehouse via packstack on centOS 6.5 , anyone know how to fix it ? I tried several times with cmd "packstack --answer-file=/root/packstack-answers-20150212-124531.txt", while it still existed.

135.252.181.62_provision_demo.pp:                    [ DONE ]
135.252.181.62_provision_glance.pp:               [ ERROR ]
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 135.252.181.62_provision_glance.pp
Error: Execution of '/usr/bin/glance -T services -I glance -K 5717051db2f442a9 -N http://135.252.181.62:35357/v2.0/ image-create --name=cirros --is-public=Yes --container-format=bare --disk-format=qcow2 --copy-from=http://download.cirros-cloud.net/0.3.1/cirros-0.3.1-x86_64-disk.img' returned 1: Request returned failure status.
You will find full trace in log /var/tmp/packstack/20150213-135908-5v9yng/manifests/135.252.181.62_provision_glance.pp.log
Please check log file /var/tmp/packstack/20150213-135908-5v9yng/openstack-setup.log for more information


vi  /var/tmp/packstack/20150213-135908-5v9yng/manifests/135.252.181.62_provision_glance.pp.log

[[mNotice: Compiled catalog for bj-jenkins04.cn.alcatel-lucent.com in environment production in 0.09 seconds^[[0m
^[[1;31mError: Execution of '/usr/bin/glance -T services -I glance -K 5717051db2f442a9 -N http://135.252.181.62:35357/v2.0/ image-create --name=cirros --is-public=Yes --container-format=bare --disk-format=qcow2 --copy-from=http://download.cirros-cloud.net/0.3.1/cirros-0.3.1-x86_64-disk.img' returned 1: Request returned failure status.
400 Bad Request
The HTTP URL is invalid.
    (HTTP 400)^[[0m
^[[1;31mError: /Stage[main]/Main/Glance_image[cirros]/ensure: change from absent to present failed: Execution of '/usr/bin/glance -T services -I glance -K 5717051db2f442a9 -N http://135.252.181.62:35357/v2.0/ image-create --name=cirros --is-public=Yes --container-format=bare --disk-format=qcow2 --copy-from=http://download.cirros-cloud.net/0.3.1/cirros-0.3.1-x86_64-disk.img' returned 1: Request returned failure status.
400 Bad Request
The HTTP URL is invalid.
    (HTTP 400)^[[0m
^[[mNotice: Finished catalog run in 139.15 seconds^[[0m
~

ERROR in /var/tmp/packstack/20150213-135908-5v9yng/openstack-setup.log:

tar --dereference -cpzf - apache ceilometer certmonger cinder concat firewall glance heat horizon inifile keystone memcached mongodb mysql neutron nova nssdb openstack packstack qpid rabbitmq remote rsync ssh stdlib swift sysctl tempest vcsrepo vlan vswitch xinetd | ssh -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null root@135.252.181.62 tar -C /var/tmp/packstack/db70c19dfa274d68a2e9a34ef4221be9/modules -xpzf -
2015-02-13 14:06:18::ERROR::run_setup::921::root:: Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 916, in main
    _main(confFile)
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 605, in _main
    runSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 584, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/setup_controller.py", line 68, in runAllSequences
    sequence.run(config=self.CONF, messages=self.MESSAGES)
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py", line 98, in run
    step.run(config=config, messages=messages)
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py", line 44, in run
    raise SequenceError(str(ex))
SequenceError: Error appeared during ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by discophile
close date 2015-02-27 00:34:06.070582

Comments

hi, I finally succeeded in installation, the WA is : manually download image and loaded it , then use packstack to install again.

discophile gravatar imagediscophile ( 2015-02-16 02:30:47 -0500 )edit

how did you downloaded it and where did you loaded it then? thank you. i am facing same or very similar issue. thanks. Error: Execution of '/usr/bin/glance --os-tenant-name services --os-username glance --os-password 3fdeb9e8d3bf4edd --os-region-name DevX --os-auth-url http://172.16.0.179:35357/ im

rogbazan gravatar imagerogbazan ( 2016-01-26 13:50:02 -0500 )edit

I am also having some problem here, can you guys tell me how did you do it? @discophile@rogbazan

Xhizor gravatar imageXhizor ( 2016-06-20 18:25:43 -0500 )edit

@Xhizor did they tell you how to do it??

fadilmohd007@gmail.com gravatar imagefadilmohd007@gmail.com ( 2019-01-22 04:59:21 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-02-15 15:39:07 -0500

Praveen N gravatar image

Try rerunning packstack..:)

edit flag offensive delete link more

Comments

Hi, thanks for your response, I just failed again.

discophile gravatar imagediscophile ( 2015-02-15 18:44:32 -0500 )edit

Hi, would you mind inform whether you are deploying openstack packstack within a VM hosted by Virtualbox/VM Manager(VMM)/VMWare workstation or else directly on the baremetal...!!!

Praveen N gravatar imagePraveen N ( 2015-02-19 11:02:31 -0500 )edit

hi, It is directly on a physical HW.

discophile gravatar imagediscophile ( 2015-02-20 02:46:41 -0500 )edit

hi, check with the repo list and remove the unwanted repos using the command rpm -e <unwantedrepo> then start your procedural steps from beginning and run packstack. Let me know if any...

Praveen N gravatar imagePraveen N ( 2015-02-26 03:55:02 -0500 )edit

hi, thanks for your suggestion, I have fixed this issue via manually create image, I added what I did in my commented in 2/16.

discophile gravatar imagediscophile ( 2015-02-27 00:32:44 -0500 )edit
0

answered 2015-02-13 13:59:21 -0500

It kinda looks like Glance isn't running. Try and start it ('sudo service openstack-glance-api start'); if that works, then re-run Packstack.. if that doesn't work, then at least you know to look at the Glance logs next. :)

edit flag offensive delete link more

Comments

hi, thanks for your response. I followed your suggestion then I found more errors,I upgraded gmp then rebuilded PyCrypto , at last try again with packstack , it still had the same error which I have pasted. Any more suggestion ?

discophile gravatar imagediscophile ( 2015-02-15 18:44:09 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-02-13 02:09:37 -0500

Seen: 1,620 times

Last updated: Feb 15 '15