Ask Your Question
0

Openvswitch module error on Neutron networking

asked 2015-02-11 12:43:40 -0500

zipmaster07 gravatar image

I'm setting up OpenStack using Juno and the Debian install documentation. I'm trying to get neutron setup on my networking node but I'm running into an error with the openvswitch service.

I've installed the following packages:

  • neutron-plugin-openvswitch-agent
  • openvswitch-datapath-dkms
  • openvswitch-datapath-source
  • neutron-l3-agent neutron-dhcp-agent
  • neutron-metadata-agent

When i try to start the openvswitch service it throws an error:

service openvswitch-switch start
ERROR: could not insert 'openvswitch': Operation not permitted
Inserting openvswitch module ... failed!
libkmod: ERROR ../libkmod/libkmod-module.c:753 kmod_module_remove_module: could not remove 'bridge': Operation not permitted
Error: could not remove module bridge: Operation not permitted
removing bridge module ... failed!
ovsdb-server is already running.
ERROR: could not insert 'openvswitch': Operation not permitted
Inserting openvswitch module ... failed!
libkmod: ERROR ../libkmod/libkmod-module.c:753 kmod_module_remove_module: could not remove 'bridge': Operation not permitted
Error: could not remove module bridge: Operation not permitted
removing bridge module ... failed!
Enabling remote OVSDB managers.

I also don't see the openvswitch module in /etc/modules:

root@thinknet:~# cat /etc/modules | grep openvswitch
root@thinknet:~# lsmod | grep openvswitch
root@thinknet:~#

and I can't load it either:

modprobe openvswitch
ERROR: could not insert 'openvswitch': Operation not permitted

I read in another post that openvswitch-brcompat should be installed, but I get an error when trying to install that:

apt-get install openvswitch-brcompat
[...]

The following packages have unmet dependencies:
 openvswitch-brcompat : Depends: openvswitch-switch (= 1.4.2+git20120612-9.1~deb7u1) but 2.1.0+git20140411-3~bpo70+1 is to be installed
                        Recommends: bridge-utils but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Any recommendations would be appreciated.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-02-16 22:56:49 -0500

Moe gravatar image

I suggest you to follow exactly step by step the original juno/debian manual which version of debian are you using the manual is working with wheezy.

another cause to this problem may be in your repository and package lists it is important that the packages are coming from which repo in this case I suggest you to revise the very first steps in basic ENV. in the manual.

also leave here :

service neutron-plugin-openvswitch-agent status
service openvswitch-switch status
service neutron-l3-agent neutron-dhcp-agent status

so the problem can be analyzed.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-11 12:43:40 -0500

Seen: 892 times

Last updated: Feb 16 '15