Ask Your Question
1

Start VM: failed to allocate the network(s), not rescheduling

asked 2015-02-11 07:38:54 -0500

Peffi gravatar image

updated 2015-02-14 11:52:31 -0500

Hello, i want to run a 3 Node Enviroment with CentOS 7 and Openstack Juno.

1 Controller Node 1 Network Node 1 Compute Node

I followed this instruction: http://docs.openstack.org/juno/instal...

I have installed all Modules and now i want run a VM.

When i want to start a VM via the Dashboard i get the failure after a few minutes:

failed to allocate the network(s), not rescheduling

When execute this command: nova service-list

then i get:

+----+------------------+-----------------------+----------+----------+-------+----------------------------+-----------------+
| Id | Binary           | Host                  | Zone     | Status   | State | Updated_at                 | Disabled Reason |
+----+------------------+-----------------------+----------+----------+-------+----------------------------+-----------------+
| 1  | nova-scheduler   | localhost.localdomain | internal | disabled | down  | 2015-02-05T14:48:32.000000 | trial log       |
| 2  | nova-cert        | localhost.localdomain | internal | disabled | down  | 2015-02-05T14:48:45.000000 | trial log       |
| 3  | nova-conductor   | localhost.localdomain | internal | disabled | down  | 2015-02-05T14:49:00.000000 | trial log       |
| 4  | nova-consoleauth | localhost.localdomain | internal | disabled | down  | 2015-02-05T14:49:19.000000 | trial log       |
| 5  | nova-scheduler   | controller            | internal | enabled  | up    | 2015-02-11T13:40:27.000000 | -               |
| 6  | nova-cert        | controller            | internal | enabled  | up    | 2015-02-11T13:40:27.000000 | -               |
| 7  | nova-conductor   | controller            | internal | enabled  | up    | 2015-02-11T13:40:26.000000 | -               |
| 8  | nova-consoleauth | controller            | internal | enabled  | up    | 2015-02-11T13:40:27.000000 | -               |
| 9  | nova-compute     | compute1              | nova     | enabled  | up    | 2015-02-11T13:40:32.000000 | -               |
+----+------------------+-----------------------+----------+----------+-------+----------------------------+-----------------+

I have disabled the first four services because i didn't unterstand why they are on host localhost.localdomain When i enable this services then i geht the failure in the dashboard: No valid host found

My nova-api.log on the controller Node:

       2015-02-12 14:21:28.630 3463 INFO nova.osapi_compute.wsgi.server [req-48438ac7-f6fc-4a2b-9ad4-8dd2620bf0e9 None] 192.168.1.110 "GET /v2/b8b7c49f7a73463fa3ca0d2615b9680f/extensions HTTP/1.1$
2015-02-12 14:21:51.247 3456 INFO nova.osapi_compute.wsgi.server [req-37b811b3-704f-4881-a7b4-6c86c69b7d33 None] 192.168.1.110 "GET /v2/b8b7c49f7a73463fa3ca0d2615b9680f/servers/40dfe2e2-1d$
2015-02-12 14:21:51.261 3456 INFO nova.osapi_compute.wsgi.server [req-f8a7de9c-ce54-4dca-9d6f-3e1bed05ff40 None] 192.168.1.110 "GET /v2/b8b7c49f7a73463fa3ca0d2615b9680f/flavors/1 HTTP/1.1"$
2015-02-12 14:21:51.296 3456 INFO nova.osapi_compute.wsgi.server [req-644c3f4f-b6fd-40b6-841f-afba55f7cf18 None] 192.168.1.110 "GET /v2/b8b7c49f7a73463fa3ca0d2615b9680f/extensions HTTP/1.1$
2015-02-12 14:22:16.409 3463 INFO nova.osapi_compute.wsgi.server [req-2dde0bcc-7428-4043-af6e-27e8ad757f45 None] 192.168.1.110 "GET /v2/b8b7c49f7a73463fa3ca0d2615b9680f/servers/40dfe2e2-1d$
2015-02-12 14:22:16.422 3463 INFO nova.osapi_compute.wsgi.server [req-f2548c3c-d3fb-409f-aad6-ee756ff9f809 None] 192.168.1.110 "GET /v2/b8b7c49f7a73463fa3ca0d2615b9680f/flavors/1 HTTP/1.1"$
2015-02-12 14:22:16.457 3463 INFO nova.osapi_compute.wsgi.server [req-5cc351b8-1bf4-476a-9d96-725568e2d849 None] 192.168.1.110 "GET /v2/b8b7c49f7a73463fa3ca0d2615b9680f/extensions HTTP/1.1$
2015-02-12 14:22:44.070 3456 INFO nova.osapi_compute.wsgi.server [req-1b4ae5af-075d-406d-921a-acdfaa650eff None] 192.168.1.110 "GET /v2/b8b7c49f7a73463fa3ca0d2615b9680f/servers/40dfe2e2-1d$
2015-02-12 14:22:44.084 3456 INFO nova.osapi_compute.wsgi.server [req-1c26700c-8fba-4191-8188-35862c6faff2 None] 192.168.1.110 "GET /v2/b8b7c49f7a73463fa3ca0d2615b9680f/flavors/1 HTTP/1.1"$
2015-02-12 14:22:44.120 3458 INFO nova.osapi_compute.wsgi.server [req-27ad2b84-aee5-4e59-be9a-8731adad28c8 None] 192.168.1.110 "GET /v2/b8b7c49f7a73463fa3ca0d2615b9680f/extensions HTTP/1.1$
2015-02-12 14:23:14.235 3462 INFO nova.osapi_compute.wsgi.server [req-7dea5fb4-6c4e-468e-a196-8bc14e6ed7a2 None] 192.168.1.110 "GET /v2/b8b7c49f7a73463fa3ca0d2615b9680f/servers/40dfe2e2-1d$
2015-02-12 14:23:14.249 3462 ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-02-11 08:58:30 -0500

rahuk gravatar image

Hey Hey,

what say # neutron agent-list ?

edit flag offensive delete link more

Comments

I have edited it. I think there is everything OK

Peffi gravatar imagePeffi ( 2015-02-11 09:04:03 -0500 )edit

I believe neutron is searching for the localhost.localdomain and nova say it is disable. Do you have set in the nova.conf and neutron.conf the option: host=controller <- for controller host=compute1 <- for compute ? If not try it and restart all services!

regards, rahuk

rahuk gravatar imagerahuk ( 2015-02-11 10:52:03 -0500 )edit

It's still the same problem.

Peffi gravatar imagePeffi ( 2015-02-12 06:26:17 -0500 )edit

Ok the problem with the console was my failure. I haven't create a key. Nova create the machine but run in the same problem: failed to allocate the network(s), not rescheduling

Peffi gravatar imagePeffi ( 2015-02-12 07:04:23 -0500 )edit

Has nobody an idea?

Peffi gravatar imagePeffi ( 2015-02-14 11:51:26 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-02-11 07:38:54 -0500

Seen: 1,366 times

Last updated: Feb 14 '15