Ask Your Question
0

heat-client won't run, No module named utils

asked 2015-02-10 16:08:45 -0600

abrandt gravatar image

I'm trying to get the heat-client up and running on my Ubuntu 14.04 machine. I've followed instructions from:

http://docs.rackspace.com/orchestration/api/v1/orchestration-getting-started/content/Install_Heat_Client.html (http://docs.rackspace.com/orchestrati...)

But when I enter heat stack-list to test I receive the following error:

Traceback (most recent call last): File "/usr/local/bin/heat", line 7, in <module> from heatclient.shell import main File "/usr/local/lib/python2.7/dist-packages/heatclient/shell.py", line 26, in <module> from oslo.utils import encodeutils ImportError: No module named utils

I've tried re-installing python2.7-dev, re-installed setup utilities, checked that my ~/.profile had: export PATH="$HOME/.pyenv/bin:$PATH" eval "$(pyenv init -)" eval "$(pyenv virtualenv-init -)"

Any help is appreciated! Trying to get this up asap.

Thanks!

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-02-11 14:09:45 -0600

abrandt gravatar image

This fixed it:

sudo apt-get remove python-pip wget https://raw.github.com/pypa/pip/master/contrib/get-pip.py sudo python get-pip.py

Solution reference here: https://bugs.launchpad.net/ubuntu/+source/python-pip/+bug/1306991 (https://bugs.launchpad.net/ubuntu/+so...)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-10 16:08:45 -0600

Seen: 988 times

Last updated: Feb 11 '15