Ask Your Question
0

MessagingTimeout when creating instance, validate_networks?

asked 2015-02-10 12:13:09 -0500

jamesgao gravatar image

Hi everyone, I just set up Neutron in Juno on a Ubuntu 14.04 server, and I'm having trouble getting nova to boot an instance. I receive MessagingTimeout exceptions whenever I try. Neutron is verified working (initial network setup + router is pingable), but I recieve a massive trace in /var/log/nova/nova-api.log whenever I try to launch an instance:

https://gist.github.com/jamesgao/1a21896fd3fb603d54b9 (https://gist.github.com/jamesgao/1a21...)

The only line that that might indicate where to look is the validate_networks line, which I assume has something to do with neutron being inaccessible. I've googled the message, and the only relevant thing I found was here: https://bugs.launchpad.net/nova/+bug/1314756 (https://bugs.launchpad.net/nova/+bug/...) . However, I've triple-checked the configuration, and /etc/nova/nova-api.conf on all the servers have the correct setup. Any leads on what to try next? I can't seem to find any other messages in any of the dozens of log files.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-02-10 21:08:44 -0500

jamesgao gravatar image

Ok, I just managed to figure it out. The Openstack instructions located here: http://docs.openstack.org/juno/install-guide/install/apt/content/neutron-controller-node.html (http://docs.openstack.org/juno/instal...) made it seem that the nova configuration goes on the COMPUTE node. It actually needs to go on the CONTROLLER node. Once I copied the config entries into /etc/nova/nova.conf on the Controller node, this error went away!

edit flag offensive delete link more
0

answered 2016-01-12 08:00:57 -0500

kl4reg gravatar image

Hi, I should really give a "like" to you, as I have the same issue. I believe there are so many people encounter the same problem, as there are many discussions with the similar topic, unfortunately none of them get a solution, until I hit this one. To be more specific, I add the following 4 lines to my controller's nova.conf to make it works:

network_api_class = nova.network.neutronv2.api.API security_group_api = neutron linuxnet_interface_driver = nova.network.linux_net.LinuxOVSInterfaceDriver firewall_driver = nova.virt.firewall.NoopFirewallDriver

I think they should update the document.

Once again, many thanks for your answer.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-10 12:13:09 -0500

Seen: 216 times

Last updated: Feb 10 '15