Ask Your Question
0

Issues creating environment

asked 2015-02-10 03:24:59 -0500

cogitans gravatar image

updated 2015-02-10 03:38:37 -0500

I'm trying to create an environment to test "everything" regarding OpenStack in Virtualbox. To succeed that mission I'm following a guide where I have to setup everything manually ([http://askubuntu.com/questions/476371/how-do-i-use-maas-to-prepare-to-install-openstack]). By now I've completed installing MAAS, created a superuser, imported bootimages, loging into the server through the browser, configured a cluster and configured a clustercontroller.

Here's where my setup doesn't fit the guide I found. Under the "Clusters"-tab it says "0 pending clusters" and "1 accepted cluster". But it's NOT connected or any managed interfaces or nodes. If I click the cluster to set it up it states: Clustername: "Cluster master" Status: "accepted" DNSzone: "maas" Interfaces: "eth0 eth0 10.0.2.0/24 Unmanaged"

If I try to configure the interface by seting routerIP and scope of IPs I recieve the error "Error: unable to connect 'Cluster master' (4e855224-da78-4bd2-9961-2c6a91e5484b); no connections available."

How do I fix this?

I'm not able to complete any further steps in the guide as I haven't got any nodes either. And I can't add a node manuelly either as the dropdownbox of releases has NO options in it. Powermanagement the same and so forth.

How am I to advance?

Thanks in advance!

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-05-22 13:16:14 -0500

Blockquote

If I click the cluster to set it up it states: Clustername: "Cluster master" Status: "accepted" DNSzone: "maas" Interfaces: "eth0 eth0 10.0.2.0/24 Unmanaged"

Blockquote

. To solve this problem, please don't edit the cluster eth0 (clustermaster). Instead, add a new interface and complete the required fields i.e the name, interface, management(you can choose DHCP or DHCP and DNS), IP, subnetmask, etc. If you have a router, you can insert the IP, otherwise leave it blank. Make sure you save the newly created interface by clicking on the "save interface" button. That said, here is the most important thing to do: you have to use this IP of the newly created interface in the configuration files found in /etc/maas especially in the /etc/maas/maas_cluster.conf file. After this change has been made in the necessary files, remember to always save, then you do a reboot. When you must have done your reboot, the next and last thing for you to do is just to refresh your maas url (http://ip/MAAS). The result is when you now click on "clusters" you will see that you have 1 accepted and connected cluster(clustermaster), and hence you can continue where you stopped. Hope this solves your problem.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-10 03:24:59 -0500

Seen: 429 times

Last updated: May 22 '15