Ask Your Question
0

Neutron net-create HTTP503 Error

asked 2015-02-09 06:58:46 -0600

Peffi gravatar image

updated 2015-02-09 09:18:18 -0600

smaffulli gravatar image

Hello I'm new in Openstack and I want to install Openstack Juno on a 3 Node Configuration with CentOS 7.

1Node Controller 1Node Network 1Node Compute

I have installed all packages like in this instruction: http://docs.openstack.org/juno/instal...

I have created a External Network like this: http://docs.openstack.org/juno/instal...

and all worked well.

Now I want create a tenant network like this: http://docs.openstack.org/juno/instal... and I get after: neutron net-create demo-net

this Error Message: Service Unavailable (HTTP 503) (Request-ID: req-c715e768-6381-44de-b61b-18fd8fff3f2d)

I have tried the command with the Demo and the Admin User.

My /var/log/neutron/server.log:

2015-02-09 13:43:51.576 3044 INFO neutron.wsgi [-] (3044) accepted ('192.168.1.110', 60556)
2015-02-09 13:43:51.634 3044 ERROR neutron.api.v2.resource [req-c715e768-6381-44de-b61b-18fd8fff3f2d None] create failed
2015-02-09 13:43:51.634 3044 TRACE neutron.api.v2.resource Traceback (most recent call last):
2015-02-09 13:43:51.634 3044 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/site-packages/neutron/api/v2/resource.py", line 87, in resource
2015-02-09 13:43:51.634 3044 TRACE neutron.api.v2.resource     result = method(request=request, **args)
2015-02-09 13:43:51.634 3044 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/site-packages/neutron/api/v2/base.py", line 448, in create
2015-02-09 13:43:51.634 3044 TRACE neutron.api.v2.resource     obj = obj_creator(request.context, **kwargs)
2015-02-09 13:43:51.634 3044 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/site-packages/neutron/plugins/ml2/plugin.py", line 499, in create_network
2015-02-09 13:43:51.634 3044 TRACE neutron.api.v2.resource     tenant_id)
2015-02-09 13:43:51.634 3044 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/site-packages/neutron/plugins/ml2/managers.py", line 160, in create_network_segments
2015-02-09 13:43:51.634 3044 TRACE neutron.api.v2.resource     segment = self.allocate_tenant_segment(session)
2015-02-09 13:43:51.634 3044 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/site-packages/neutron/plugins/ml2/managers.py", line 192, in allocate_tenant_segment
2015-02-09 13:43:51.634 3044 TRACE neutron.api.v2.resource     raise exc.NoNetworkAvailable()
2015-02-09 13:43:51.634 3044 TRACE neutron.api.v2.resource NoNetworkAvailable: Unable to create the network. No tenant network is available for allocation.
2015-02-09 13:43:51.634 3044 TRACE neutron.api.v2.resource
2015-02-09 13:43:51.635 3044 INFO neutron.wsgi [req-c715e768-6381-44de-b61b-18fd8fff3f2d None] 192.168.1.110 - - [09/Feb/2015 13:43:51] "POST /v2.0/networks.json HTTP/1.1" 503 360 0.058279

I hope you can help me

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-02-09 09:21:26 -0600

smaffulli gravatar image

updated 2015-02-09 12:05:49 -0600

I suspect you missed a step because the logs tell you that No tenant network is available for allocation . Maybe you skipped http://docs.openstack.org/juno/instal...

For example, did you

 $ source demo-openrc.sh

?

edit flag offensive delete link more

Comments

Hello smaffulli. Thank you for your answer. Yes you are right. I have no tenant network because i can't create a network with the command neutron net-create demo-net I have no idea which step i skipped which produce these Error. I'm wondering that it was no problem to create a external network.

Peffi gravatar imagePeffi ( 2015-02-09 11:28:53 -0600 )edit

have the same issue, checked it 3 times and cannot find th emissing step!

Billias gravatar imageBillias ( 2015-02-09 11:41:10 -0600 )edit
smaffulli gravatar imagesmaffulli ( 2015-02-09 12:11:14 -0600 )edit

@Billias Think about voting the question up, too.

smaffulli gravatar imagesmaffulli ( 2015-02-09 16:55:18 -0600 )edit
0

answered 2015-02-10 06:04:59 -0600

Peffi gravatar image

I have found my problem! In the /etc/neutron/plugins/ml2/ml2_conf.ini i have pasted the Option: tunnel_id_ranges = 1:1000 in the section [ml2_type_flat]. The Right Section is [ml2_type_gre]

@Billias maybe you have a problem in your config files, too.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-09 06:58:46 -0600

Seen: 3,080 times

Last updated: Feb 10 '15