Ask Your Question
0

nova.virt.vmwareapi.driver Unable to connect to server at None

asked 2015-02-08 15:12:06 -0500

wharfedale gravatar image

Hello,

I'm configuring openstack on an esxi 5.5 machine. I've used debian wheezy for controller and compute-node. I followed an howto on the internet

I get an error on the compute node in nova-compute.log

2015-02-08 21:47:39.313 2746 CRITICAL nova.virt.vmwareapi.driver [-] Unable to connect to server at None, sleeping for 60 seconds

I've added this to nova.config

compute_driver=vmwareapi.VMwareESXDriver vmwareapi_host_ip=xxxxxx vmwareapi_host_username=xxxxx vmwareapi_host_password=xxxxxx connection_type = vmwareapi vmwareapi.integration_bridge=br-int [vmware] wsdl_loc=file:///opt/stack/vmware/SDK/vsphere-ws/wsdl/vim25/vimService.wsdl

And this to nova-compute.con

[DEFAULT] compute_driver=vmwareapi.VMwareESXDriver libvirt_ovs_bridge=br-int libvirt_vif_type=ethernet libvirt_vif_driver=nova.virt.libvirt.vif.LibvirtHybridOVSBridgeDriver libvirt_use_virtio_for_bridges=True

I've download the vsphere sdk to /opt/stack/vmware/ and the file vimService.wsdl is in the directory.

Can someone point me in the right direction?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-02-08 16:20:28 -0500

nova-compute.conf needs to have the [vmware] section populated with:

[vmware]
vmwareapi_host_ip=xxxxxx 
vmwareapi_host_username=xxxxx 
vmwareapi_host_password=xxxxxx
cluster_name = None

There are other options that are needed defined here:

http://docs.openstack.org/juno/config...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-08 15:12:06 -0500

Seen: 619 times

Last updated: Feb 08 '15