Juno : nova IncompatibleObjectVersion: Version 1.9 of InstanceList is not supported

asked 2015-02-06 07:41:42 -0600

thomas gravatar image

updated 2015-02-06 11:28:02 -0600

smaffulli gravatar image

I am trying to setup a fresh juno openstack environment (1 controller-node, 1 network-node and 1 compute-node). Everything works fine except instance creation.

Seeing following message in the log file

    **IncompatibleObjectVersion: Version 1.9 of InstanceList is not supported**

-controller-node and compute-node are on same nova version (2.19.0)

did the following tasks as part of troubleshooting. still the issue persists. -executing "nova-manage db sync" on the controller -delete and recreate nova DB, as well as remove & reinstall of all nova packages on both controller-node & compute-node

edit retag flag offensive close merge delete

Comments

Edit your question, explain how you installed openstack: maybe some broken package?

smaffulli gravatar imagesmaffulli ( 2015-02-06 11:28:36 -0600 )edit

That's simple configuration. Install RDO Juno via packstack multi-node answer-file wouldn't have any problems with package consistency.

dbaxps gravatar imagedbaxps ( 2015-02-06 11:37:40 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-02-06 12:44:46 -0600

Hey hi, as per the OpenStack documentation-- each service has its set of objects, each with a version attached. When a client attempts to call an object method, the server checks to see if the version of that object matches (in a compatible way) its object implementation. If so, everything is fine, and if not, raises an exception. My suggestion for you is,

  1. If possible, try to upgrade/downgrade the versions of nova services.
  2. Try to sync database version with nova services.
edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-06 07:41:42 -0600

Seen: 636 times

Last updated: Feb 06 '15