Ask Your Question
0

nova get-serial-console produces HTTP 400 error

asked 2015-02-06 03:55:41 -0600

updated 2015-02-06 06:31:46 -0600

Hi,

I am testing Openstack Juno, using a dedicated controller and two compute nodes. For this test, would like to access the serial console port of my VM's as currently is possible using nova-get-serial-console.

I am using Cirros as a test VM.

As documented elsewhere, I started the serial proxy:

2015-02-06 09:41:02.038 15179 INFO nova.console.websocketproxy [-] WebSocket server settings:
2015-02-06 09:41:02.039 15179 INFO nova.console.websocketproxy [-]   - Listen on 0.0.0.0:6083
2015-02-06 09:41:02.039 15179 INFO nova.console.websocketproxy [-]   - Flash security policy server
2015-02-06 09:41:02.039 15179 INFO nova.console.websocketproxy [-]   - No SSL/TLS support (no cert file)
2015-02-06 09:41:02.040 15179 INFO nova.console.websocketproxy [-]   - proxying from 0.0.0.0:6083 to None:None

When I issue a telnet to it on port 6083, I get a connection, so it is running.

But when I request a serial console, I get the following:

[node-4 ~]# nova get-serial-console test6
ERROR (BadRequest): Unavailable console type serial. (HTTP 400) (Request-ID: req-bbec8a4e-58ff-40f2-ac0e-503c0be9777b)

Does anyone have any insight what might be the problem?

Thanks in advance for your support.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-02-06 08:14:41 -0600

larsks gravatar image

Have you enabled serial console support on your compute nodes? You would need to edit /etc/nova/nova.conf on those systems, and set:

[serial_console]
enabled=true

# Location of serial console proxy. (string value)
base_url=ws://<public_ip>:6083/

# IP address on which instance serial console should listen
# (string value)
listen=0.0.0.0

# The address to which proxy clients (like nova-serialproxy)
# should connect (string value)
proxyclient_address=<host_ip>

Where:

  • <public_ip> is the public ip address of whichever host is running nova-serialproxy, and

  • <host_ip> is the ip address of your compute host.

The serial console configuration is very similar to the VNC console configuration.

I wrote up some serial console documentation here.

edit flag offensive delete link more

Comments

Thanks! Indeed the issue was that I didn't update the nova.conf of the compute nodes. Now it seems to work.

ph0tek gravatar imageph0tek ( 2015-02-09 03:14:01 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-06 03:55:41 -0600

Seen: 5,974 times

Last updated: Feb 06 '15