How can I use a vlan interface as an external network?

asked 2015-02-05 10:29:49 -0600

Nick zheng gravatar image

updated 2015-02-05 10:33:30 -0600

Hey Guys,

I have a problem with external network configure in openstack juno! I hava only one network node with one physical external network interface which can be used, but I need config two different ip ranges as floating ips, so I use vlan on it, but I can't config this successfully. here are some configurations I use:

network node:


        type_drivers = flat,vlan,gre
        tenant_network_types = gre
        mechanism_drivers = openvswitch

        flat_networks = *

        network_vlan_ranges = external1
        local_ip =
        tunnel_type = gre
        enable_tunneling = True
        bridge_mappings = externa11:br-ex-1

        use_namespaces = True
        external_network_bridge =
        gateway_external_network_id =


    [root@network neutron]# ovs-vsctl show
   Bridge br-int
    fail_mode: secure
    Port "tap58e3c93a-79"
        tag: 1
        Interface "tap58e3c93a-79"
            type: internal
    Port "qg-a609bc07-5a"
        tag: 4095
        Interface "qg-a609bc07-5a"
            type: internal
    Port br-int
        Interface br-int
            type: internal
    Port patch-tun
        Interface patch-tun
            type: patch
            options: {peer=patch-int}
    Port "qr-2be6acec-c7"
        tag: 1
        Interface "qr-2be6acec-c7"
            type: internal
    Port "int-br-ex-1"
        Interface "int-br-ex-1"
            type: patch
            options: {peer="phy-br-ex-1"}
Bridge br-tun
    Port br-tun
        Interface br-tun
            type: internal
    Port patch-int
        Interface patch-int
            type: patch
            options: {peer=patch-tun}
    Port "gre-0a00011f"
        Interface "gre-0a00011f"
            type: gre
            options: {df_default="true", in_key=flow, local_ip="", out_key=flow, remote_ip=""}
Bridge "br-ex-1"
    Port "br-ex-1"
        Interface "br-ex-1"
            type: internal
    Port "phy-br-ex-1"
        Interface "phy-br-ex-1"
            type: patch
            options: {peer="int-br-ex-1"}
    Port "eth2.100"
        Interface "eth2.100"
ovs_version: "2.1.3"

I hope that someone can give me some advice and your reply would be highly appreciate.

edit retag flag offensive close merge delete


I don't know if you still need help, but you seemed to have left out some information. For instance you want to use vlans but your neutron.conf file does not have the [ml2_type_vlan] configuration. I currently have the same setup and I have internal networks on 192 and external on my vlan networks.

foster gravatar imagefoster ( 2015-03-25 07:38:38 -0600 )edit