Ask Your Question
0

sriov supported_pci_vendor_devs is ignored

asked 2015-02-04 10:05:19 -0500

etlv gravatar image

updated 2015-02-05 12:00:55 -0500

smaffulli gravatar image

Im using openstack Juno release over Ubuntu 14.04.1 OS.

# uname -a
Linux controller 3.13.0-45-generic #74-Ubuntu SMP Tue Jan 13 19:36:28 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

I would like to use the sriov feature as explained in: https://wiki.openstack.org/wiki/SR-IO...

However for some reason it seems like the supported_pci_vendor_devs parameter I configured in ml2_conf_sriov.ini file is not taken by neutron server. it seems like the default value of supported_pci_vendor_devs = 15b3:1004 is always used no matter what.

1) the config file:

# egrep -v '^(#|$)'  /etc/neutron/plugins/ml2/ml2_conf_sriov.ini
[ml2_sriov]
supported_pci_vendor_devs = 8086:10ed, 8086:10fb
agent_required = True
[sriov_nic]

2) the loaded supported pci vendor during service restart:

# service neutron-server restart
neutron-server stop/waiting
neutron-server start/running, process 24673
# cat /var/log/neutron/server.log | grep -i vendor
2015-02-04 17:51:08.688 24553 DEBUG neutron.service [-] ml2_sriov.supported_pci_vendor_devs = ['15b3:1004', '8086:10c9'] log_opt_values /usr/lib/python2.7/dist-packages/oslo/config/cfg.py:2000

3) After configuring the nuetron.conf, ml2_conf.ini and ml2_conf_sriov.ini, I did without any help:

# su -s /bin/sh -c "neutron-db-manage --config-file /etc/neutron/neutron.conf \
  --config-file /etc/neutron/plugins/ml2/ml2_conf.ini upgrade juno" neutron 
  #neutron-server --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugins/ml2/ml2_conf.ini --config-file /etc/neutron/plugins/ml2/ml2_conf_sriov.ini

any ideas?

edit retag flag offensive close merge delete

Comments

How you are running the service neutron-server and neutron-sriov-nic-agent?

If manually, then first verify whether these process are already running or not. if running then stop it and then run manually.

ps -elf | grep neutron-server ?

Ranjit gravatar imageRanjit ( 2015-02-05 02:15:18 -0500 )edit

Thanks for the reply. 1. I'm not running the agent on the controller, but I dont think its related (is it?). 2. It seems like the problem is related to the fact that neutron server is not loading plugin config files as far as I can see in the log files...

etlv gravatar imageetlv ( 2015-02-05 03:21:17 -0500 )edit

I use "neutron-server --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugins/ml2/ml2_conf.ini --config-file /etc/neutron/plugins/ml2/ml2_conf_sriov.ini" to load the config files, however in neutron server.log I see after service restart that the sriov config file is not taken.

etlv gravatar imageetlv ( 2015-02-05 03:23:04 -0500 )edit

good to know that you understood what was happening.

service startup files for ubuntu are in /etc/init path

update the file related to neutron-server and neutron-sriov-nic-agent with addtional --config-file option, then service command will work.

Ranjit gravatar imageRanjit ( 2015-02-05 04:17:51 -0500 )edit

Thanks. working.

etlv gravatar imageetlv ( 2015-02-05 05:56:24 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-02-05 03:32:11 -0500

etlv gravatar image

Thanks for the "ps" tip. I found out that there was already neutron-server service running, I had to stop it, then run the command above pointing the config files. now the config files are loaded. how do I force it to load the config files on start up?

edit flag offensive delete link more
0

answered 2018-08-27 03:16:58 -0500

Dipak Warade gravatar image

edit the service definition

/usr/lib/systemd/system/neutron-sriov-nic-agent.service

you will add

--config-file <path to="" your="" config="" file="">

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-04 10:05:19 -0500

Seen: 507 times

Last updated: Aug 27 '18