Ask Your Question
0

Why won't Nova start?

asked 2013-10-15 14:39:22 -0600

Kiloseven gravatar image

updated 2013-10-15 14:50:46 -0600

Still mushing my way through Bilel Msekni's OpenStack Grizzly Install Guide for a single-server install.

Nova has stopped. It worked before, but now /var/log/boot.log shows the Nova services (only) fail at boot time.

I have a Keystone user-list and a Glance image-list, so my creds file is OK, but as per the Nova section of the instructions first cited above, when I run nova-manage service list I should see an instance of Nova running, and I do not, just the title line but no data.

FYI, eth0 as per ifconfig is on 10.10.10.51 and eth1, set as the primary web interface when Ubuntu 13.04 was installed, is dhcp'd so I can reach the web. /etc/network/interfaces has these active lines as per this step in the procedure:

auto lo
iface lo inet loopback
auto eth1
iface eth1 inet dhcp
auto eth0
iface eth0 inet static
address 10.10.10.51
netmask 255.255.255.0

Your kind help would truly be appreciated.

edit retag flag offensive close merge delete

Comments

make sure you enable all services to start on boot chkconfig openstack-nova-<servicename> on

sngirame gravatar imagesngirame ( 2013-10-16 09:39:11 -0600 )edit

Ain't no chkconfig in Ubuntu. Using Ubuntu 13.04 server as base for server as per the aforementioned instructions cited above. http://askubuntu.com/questions/221293/why-is-chkconfig-no-longer-available-in-ubuntu suggested use of sysv-rc-conf which I shall go explore. Thank you kindly for the tip, too!

Kiloseven gravatar imageKiloseven ( 2013-10-16 13:23:31 -0600 )edit

http://upstart.ubuntu.com/cookbook/ explains the preferred method, better than installing and using sysv-rc-conf which is soooo RedHat...

Kiloseven gravatar imageKiloseven ( 2013-10-16 15:40:25 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-10-16 00:24:09 -0600

Anand TS gravatar image

Did you source adminrc.sh file??

What is the output of nova service-list ??

nova-compute service usually goes down after server reboot. You can try this debug command to make this service up.

/usr/bin/nova-compute --config-file /etc/nova/nova.conf.

edit flag offensive delete link more

Comments

I cant help you more as I'm not familiar with Bilel procedure. If you get any clue pls it post here. Anand

Anand TS gravatar imageAnand TS ( 2013-10-17 04:48:47 -0600 )edit

There's no adminrc.sh in the system, checked with locate and find both. The output of nova service-list is a heading with nothing running. /usr/bin/nova-compute --config-file /etc/nova/nova.conf complains about nova-conductor not running, so I launched that then nova-compute, but the nova service-list is still empty. The Bilel procedure is at https://github.com/mseknibilel/OpenStack-Grizzly-Install-Guide/blob/OVS_SingleNode/OpenStack_Grizzly_Install_Guide.rst and I am in section 6, Nova.

Kiloseven gravatar imageKiloseven ( 2013-10-18 16:52:07 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-10-15 14:39:22 -0600

Seen: 198 times

Last updated: Oct 16 '13