Ask Your Question
0

floating IP only available after reboot

asked 2015-02-03 07:20:08 -0600

Johan Blaauw gravatar image

updated 2015-02-04 14:38:50 -0600

rbowen gravatar image

Hi,

The floating IP is only reachable after I reboot the system. I've set the necessary security setting to be able to ping the VM. The openstack version is Juno on CentOS7 installed with RDO. Please help to solve this problem.

If you need more config or log files please let me know.

ifcfg-br-ex:
DEVICE=br-ex
DEVICETYPE=ovs
TYPE=OVSBridge
BOOTPROTO=none
IPADDR=94.124.95.2
NETMASK=255.255.255.224
ONBOOT=yes
GATEWAY=94.124.95.1
PROMISC=yes

ifcfg-eth0:
DEVICE=eth0
NAME=eth0
NM_CONTROLLED=no
ONBOOT=yes
TYPE=OVSPort
DEVICETYPE=ovs
OVS_BRIDGE=br-ex
PROMISC=yes
UUID="e0b42db9-dc15-4a08-bc52-92a1b02f1b04"
HWADDR="00:25:90:93:D8:34"

l3_agent.ini:

[DEFAULT]
# Show debugging output in log (sets DEBUG log level output)
# debug = False
debug = False

# L3 requires that an interface driver be set. Choose the one that best
# matches your plugin.
# interface_driver =
interface_driver =neutron.agent.linux.interface.OVSInterfaceDriver

# Example of interface_driver option for OVS based plugins (OVS, Ryu, NEC)
# that supports L3 agent
# interface_driver = neutron.agent.linux.interface.OVSInterfaceDriver

# Use veth for an OVS interface or not.
# Support kernels with limited namespace support
# (e.g. RHEL 6.5) so long as ovs_use_veth is set to True.
# ovs_use_veth = False

# Example of interface_driver option for LinuxBridge
# interface_driver = neutron.agent.linux.interface.BridgeInterfaceDriver

# Allow overlapping IP (Must have kernel build with CONFIG_NET_NS=y and
# iproute2 package that supports namespaces).
# use_namespaces = True
use_namespaces = True

# If use_namespaces is set as False then the agent can only configure one router.

# This is done by setting the specific router_id.
# router_id =

# When external_network_bridge is set, each L3 agent can be associated
# with no more than one external network. This value should be set to the UUID
# of that external network. To allow L3 agent support multiple external
# networks, both the external_network_bridge and gateway_external_network_id
# must be left empty.
gateway_external_network_id = e0578c7c-302f-43fb-be4e-30bcdcf12617

# Indicates that this L3 agent should also handle routers that do not have
# an external network gateway configured.  This option should be True only
# for a single agent in a Neutron deployment, and may be False for all agents
# if all routers must have an external network gateway
# handle_internal_only_routers = True
handle_internal_only_routers = False

# Name of bridge used for external network traffic. This should be set to
# empty value for the linux bridge. when this parameter is set, each L3 agent
# can be associated with no more than one external network.
# external_network_bridge = br-ex
external_network_bridge = br-ex

# TCP Port used by Neutron metadata server
# metadata_port = 9697
metadata_port = 9697

# Send this many gratuitous ARPs for HA setup. Set it below or equal to 0
# to disable this feature.
# send_arp_for_ha = 3
send_arp_for_ha = 3

# seconds between re-sync routers' data if needed
# periodic_interval = 40
periodic_interval = 40

# seconds to start to sync routers' data after
# starting agent
# periodic_fuzzy_delay = 5
periodic_fuzzy_delay = 5

# enable_metadata_proxy, which is true by default, can be set to False
# if the Nova metadata server is not available
# enable_metadata_proxy = True
enable_metadata_proxy = True

# Location of Metadata Proxy UNIX domain socket
# metadata_proxy_socket = $state_path/metadata_proxy

# router_delete_namespaces, which is false by default, can be set to True if
# namespaces can ...
(more)
edit retag flag offensive close merge delete

Comments

I have the same problem. The only help I can offer you is just restart the l3-agent. no need to reboot.

akileshk1597 gravatar imageakileshk1597 ( 2015-02-12 00:45:17 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-02-12 02:20:47 -0600

I found why I had this problem. In my case I was running two l3-agents for two external networks. Since your configuration file suggest that you have explicitly set external_gateway_network and external_network_bridge I belive you are doing the same mistake. Stop the other l3-agent. unset the above two params(this will enable the single running l3-agent to take care of woth external networks and routers)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-03 07:20:08 -0600

Seen: 586 times

Last updated: Feb 04 '15