Ask Your Question
0

Nova compute fails: RemoteError: Remote error: NoSuchOptError no such option: memcached_servers

asked 2015-02-02 08:13:50 -0500

Krist gravatar image

When I try to start an instance this fails. The message I see in compute.log is:

2015-02-02 14:55:46.903 13368 TRACE nova.compute.manager [instance: 7265cacc-8adb-4aed-9d33-076733ff0a12] RemoteError: Remote error: NoSuchOptError no such option: memcached_servers
2015-02-02 14:55:46.903 13368 TRACE nova.compute.manager [instance: 7265cacc-8adb-4aed-9d33-076733ff0a12] [u'Traceback (most recent call last):\n', u'  File "/usr/lib/python2.6/site-packages/nova/openstack/common/rpc/amqp.py", line 461, in _process_data\n    **args)\n', u'  File "/usr/lib/python2.6/site-packages/nova/openstack/common/rpc/dispatcher.py", line 172, in dispatch\n    result = getattr(proxyobj, method)(ctxt, **kwargs)\n', u'  File "/usr/lib/python2.6/site-packages/nova/conductor/manager.py", line 513, in get_ec2_ids\n    ec2_ids[\'instance-id\'] = ec2utils.id_to_ec2_inst_id(instance[\'uuid\'])\n', u'  File "/usr/lib/python2.6/site-packages/nova/api/ec2/ec2utils.py", line 189, in id_to_ec2_inst_id\n    int_id = get_int_id_from_instance_uuid(ctxt, instance_id)\n', u'  File "/usr/lib/python2.6/site-packages/nova/api/ec2/ec2utils.py", line 45, in memoizer\n    _CACHE = memorycache.get_client()\n', u'  File "/usr/lib/python2.6/site-packages/nova/openstack/common/memorycache.py", line 39, in get_client\n    memcached_servers = CONF.memcached_servers\n', u'  File "/usr/lib/python2.6/site-packages/oslo/config/cfg.py", line 1652, in __getattr__\n    raise NoSuchOptError(name)\n', u'NoSuchOptError: no such option: memcached_servers\n'].

I see a similar message in scheduler.log.

What does this message mean?

As far as I know "memcached_servers" is a valid config parameter. In my config this is set to "none".

What is going on here?

edit retag flag offensive close merge delete

Comments

What version of Nova are you running? What happens if you just comment out the line?

larsks gravatar imagelarsks ( 2015-02-02 09:02:13 -0500 )edit

This is havana. Commenting out the line makes no difference. It hinkg however that the error is thrown by the request for CONF.memcached_servers. So it expects this parameter. Maybe I just need to add it to every section of the config...

Krist gravatar imageKrist ( 2015-02-03 01:07:21 -0500 )edit

Another observation: When we do a test starting lots of instances about 5% are succesful, and are started. The rest fail. This appears to be a random error with a high probability... But why?

Krist gravatar imageKrist ( 2015-02-03 09:54:44 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-02-05 01:06:10 -0500

Krist gravatar image

The cause was that after adding the memcached_servers setting to nova.conf and restarting the nova services a few processes were not properly stopped and restarted. As a restult there were nova conductor workers running with an outdated config. When they consumed messages from the queues they of course threw errors, which got passed back through the queues. It's only after I started tracing the queues that I discovered this.

So the moral of the story: When you do a restart, make sure that you do indeed restart everything...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-02 08:13:50 -0500

Seen: 595 times

Last updated: Feb 05 '15