Ask Your Question

What is expected behavior on setting admin_state_up=false for neutron ports?

asked 2015-02-02 08:01:52 -0500

vthapar gravatar image

I have an ODL [compiled off master] + Openstack [stable/juno devstack] setup. I am able to bring up VMs. When I set admin_state of neutron port in-use by VM to false, VM can still ping and OVS also shows link and admin state of OF Port as up.

Is this the expected behavior or bug with ODL implementation?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted

answered 2015-02-02 13:17:08 -0500

Changing admin state should also reflect the "physical" status of the port as well.

If you set admin state up to false then you should not be able to reach the IP anymore.

Looks like a bug.

edit flag offensive delete link more


Thanks for the reply. Any idea which part of code/module sets the physical status as down for OVS Neutron Agent setup? Would it be nova-compute, OVS Agent or something else? This would help figure out if bug is in Neutron or ODL code.

vthapar gravatar imagevthapar ( 2015-02-02 23:05:15 -0500 )edit

The api call goes to neutron server which will call the agent on the compute which should set the ovs port to down.

I tested with neutron using ml2 with ovs and it worked.also test with neutron and nsx and it also worked .

sfcloudman gravatar imagesfcloudman ( 2015-02-03 00:50:16 -0500 )edit

Thank you for the follow up. There is no agent on compute node when ODL is used, so that could be why it never goes 'down'. Will raise a bug with ODL.

vthapar gravatar imagevthapar ( 2015-02-09 04:11:16 -0500 )edit

answered 2017-05-16 02:58:57 -0500 gravatar image

If this is still actual for you, I think you hit the following bug - If yes, mark it as 'affects me'.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2015-02-02 08:01:52 -0500

Seen: 2,030 times

Last updated: May 16 '17