Ask Your Question
0

Fuel deployment: host unreachable on br-mgmt

asked 2015-02-02 05:21:00 -0600

cubusbacau gravatar image

Hi,

I have deployed 3 physical nodes using Fuel in a 1+2 configuration: 1 controller/mongo, 2 compute/storage. The nodes have 2 physical nics: eth0 and eth1. Cluster was deployed with Neutron networking/Open vSwitch

On eth0 it configured 3 networks: br-mgmt (with vlan tag 1199), br-storage (also with vlan tag 1198) and br-fw-admin (Without vlan tag). After deployment the nodes can talk to each other on br-fw-admin ips but not on br-mgmt ips, so after install, compute service on compute node cannot reach rabbitmq (EHOSTUNREACH).

As a note: Eth0 interfaces are connected to a managed switch and are part of a vlan segment (tag 1011). Eth1 interfaces are connected to a public managed switch without vlan tagging.

Question: how should i configure the interfaces so that traffic passes between nodes on br-mgmt and br-storage?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-02-02 09:52:50 -0600

NoNoNoo gravatar image

updated 2015-02-02 09:53:32 -0600

The ports of the managed switch connected to eth0 interfaces should be configured in trunk mode in order to allow the following types of vlan traffic:

  • br-mgmt with vlan tag 1199
  • br-storage with vlan tag 1198
  • br-fw-admin that is traffic sended without any tag so you have to set any pvid for these ports(you wrote the pvid 1011 I think)

Using HP/Comware syntax you have to configure each switch port connected to eth0 interfaces as in the following example:

[HP]interface FuelEth0InterfaceName
[FuelEth0InterfaceName]port link-type trunk       # Configure trunk lynk type 
[FuelEth0InterfaceName]undo port trunk permit vlan 1  # Remove default vlan 1
[FuelEth0InterfaceName]port trunk permit vlan 1199    # Allow tagged traffic for vlan 1199
[FuelEth0InterfaceName]port trunk permit vlan 1198    # Allow tagged traffic for vlan 1199
[FuelEth0InterfaceName]port trunk pvid vlan 1011      # Allow untagged packets and assign to it the vlan id 1011
[FuelEth0InterfaceName]undo shutdown
[FuelEth0InterfaceName]quit

You maybe have eth0 switch ports configured in access mode that allow only the packets without vlan tag, indeed you can ping two fuels nodes using br-fw-admin interfaces. You should configure these ports on the switch in trunk mode.

edit flag offensive delete link more

Comments

So... you mean i have to configure the switch itself to pass traffic with vlans 1199 and 1198? I don't think i can do that as i don't have access to it.

Is there a way to "untag" the br-mgmt and br-storage so that it works like br-fw-admin?

Thanks

cubusbacau gravatar imagecubusbacau ( 2015-02-02 10:11:34 -0600 )edit

Yes if you use VLAN tag in fuel you have to configure also these vlan on the switch. Are you using fuel installation of mirantis openstack? You can "untag" br-mgmt and br-storage but you need other 2 interfaces(for example eth2 and eth3) for each openstack server

NoNoNoo gravatar imageNoNoNoo ( 2015-02-02 10:50:52 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-02 05:21:00 -0600

Seen: 1,006 times

Last updated: Feb 02 '15