Unable to start any new VMs - stuck in build / scheduling status [closed]

asked 2013-10-15 09:02:41 -0600

Vee-Tess gravatar image

Afternoon all,

I've inherited an Openstack Folsom (nova-manage version list returns '2012.2.2-dev') setup.

Until recently all was well - users could create VMs at will. However, we recently had a network issue that caused the switch that the controller and compute nodes are plugged into. The knock-on effect is that it appears that 'id' in nova.instances and nova.instance_info_caches is out of sync.

When I try to create a new instance, it just gets stuck in 'build' status (the task stays at 'scheduling'. nova list on the cli just returns that the Status is 'Build' as well (well no surprise there really...)

On digging deeper through the MySQL tables, it appears that the id generated for the instance in 'instances' differs from the id that references that uuid in 'instance_info_caches' by about 5. There are no errors in nova.log

So my question is really - can I just insert NULL records into instances in order to get it to "catch up" with instance_info_caches ???

VT

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by rbowen
close date 2016-06-21 14:22:20.241200

Comments

The version of OpenStack that this is opened against has been declared EOL as per http://releases.openstack.org/ Please open a new issue if you are still seeing this problem with a more recent, supported version of OpenStack. Thanks.

rbowen gravatar imagerbowen ( 2016-06-21 14:22:16 -0600 )edit