Ask Your Question
1

dashboard can't retrieve anything or do anything

asked 2015-01-30 23:40:48 -0600

Waid gravatar image

updated 2015-01-31 00:06:39 -0600

Hi there, I'd installed the OpenStack by devStack successfully(installed in VirtualBox Ubuntu 12.04).

After that , I can connect to the dashboard by the Chrome browser.

But the first warning jumped out 'Error: Unable to retrieve usage information' after I logged in.

Then I press 'Project' and it showed 'Error: Unable to retrieve usage information.'

I found that no matter what I pressed, it always get the messages to inform me that it can't retrieve anything.

And when I press 'image', a page show up with title: CommunicationError at /project/images/ Error finding address for htt p://10.0.1.15: 9292/v1/images/detail?sort_key=created_at&sort_dir=desc&limit=1000: ('Connection aborted.', error(111, 'Connection refused'))

I am a newbie don't know where to check.

Not sure what's wrong with it. Any help? I am glad to provide further info. if you like.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-01-31 10:34:34 -0600

Waid gravatar image

updated 2015-01-31 10:54:44 -0600

Now the problem is solved, I give my solution as a reference:

The problem occurred when I set my localrc as the following:

HOST_IP=10.0.1.15

FLAT_INTERFACE=eth0

FLOATING_RANGE={-...not important for this case}

(module passwords....)

Here, my network setting is actually: eth0:dhcp(Virtualbox NAT give it IP), eth1: static IP: 10.0.1.15(Virtualbox host-only network)

The problem is solved by setting localrc as the following:

HOST_IP=10.0.1.15

FLAT_INTERFACE=br100

PUBLIC_INTERFACE=eth1

FLOATING_RANGE={-...not important for this case}

(module passwords....)

In this setting, I changed my /etc/network/interfaces as:

eth0:dhcp, br100+eth1:static IP:10.0.1.15

I guess the problem is solved because I changed FLAT_INTERFACE from eth0 to eth1. eth1 is the entry to the openstack host.

edit flag offensive delete link more
0

answered 2015-01-31 01:57:30 -0600

Hi Waid,

1. Ensure whether your database is working properly.
2. Enable the logs, and try to figure out the cause.

To enable log, add the following lines to the localrc file.

LOGFILE=/opt/stack/logs/stack.sh.log
SCREEN_LOGDIR=/opt/stack/logs/screen
edit flag offensive delete link more

Comments

I, like Waid, am new to openstack.

Experiencing the same error. Pretty sure that its not the FLAT_INTERFACE problem. Where is the localrc file to make the above suggested changes?

merlinjim gravatar imagemerlinjim ( 2016-06-07 09:29:02 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-01-30 23:40:48 -0600

Seen: 6,691 times

Last updated: Jan 31 '15