Ask Your Question
0

devstack - horizon/run_tests.sh: No module named backports.ssl_match_hostname

asked 2015-01-30 19:52:22 -0600

GLaupre gravatar image

updated 2015-02-10 12:40:29 -0600

Hello,

I want to deploy a new devstack on a CentOS 7 machine. I am encountering an error on run_test.sh for horizon:

cd /opt/stack/horizon
 + ./run_tests.sh -N --compilemessages
Traceback (most recent call last):
File "/opt/stack/horizon/manage.py", line 23, in <module>
    execute_from_command_line(sys.argv)
File "/usr/lib/python2.7/site-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
     utility.execute()
File "/usr/lib/python2.7/site-packages/django/core/management/__init__.py", line 392, in execute
     self.fetch_command(subcommand).run_from_argv(self.argv)
File "/usr/lib/python2.7/site-packages/django/core/management/__init__.py", line 261, in fetch_command
     commands = get_commands()
File "/usr/lib/python2.7/site-packages/django/core/management/__init__.py", line 107, in get_commands
     apps = settings.INSTALLED_APPS
File "/usr/lib/python2.7/site-packages/django/conf/__init__.py", line 54, in __getattr__
    self._setup(name)
File "/usr/lib/python2.7/site-packages/django/conf/__init__.py", line 49, in _setup
     self._wrapped = Settings(settings_module)
File "/usr/lib/python2.7/site-packages/django/conf/__init__.py", line 132, in __init__
    % (self.SETTINGS_MODULE, e)
ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named backports.ssl_match_hostname

I have the package installed:

rpm -qa | grep backport
python-backports-ssl_match_hostname-3.4.0.2-4.el7.noarch
python-backports-1.0-6.el7.noarch

It seems a configuration issue, but I have no idea how to fix that. Any suggestion? Tks

edit retag flag offensive close merge delete

Comments

I still didn't fix that problem. Any help?

GLaupre gravatar imageGLaupre ( 2015-02-10 12:39:16 -0600 )edit

Hello, I have same problem now. Did you solve it?

kim0412 gravatar imagekim0412 ( 2015-02-22 23:45:45 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-03-28 01:01:58 -0600

dmn gravatar image

For those who face the same problem in the future, pip install backports.ssl_match_hostname worked for me. For some reason pip install fixes the issue and not yum install.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-01-30 19:52:22 -0600

Seen: 1,031 times

Last updated: Feb 10 '15