Ask Your Question
1

swift stat [Errno 111] Connection refused Icehouse

asked 2015-01-27 04:03:12 -0500

travhoang77 gravatar image

Hi fellow Openstack enthusiasts.

I am having trouble verifying my proxy and swift storage node from the ICEHOUSE installation guide. I am running all my nodes on real machines. (no VMs). I have 1 proxy node and 1 storage node.

I run "swift stat" on my controller and I get this error

HTTPConnectionPool(host='controller', port=8080): Max retries exceeded with url/v1/AUTH_c78ebdbc003f49329bfc821c1e3ec937 (Caused by <class 'socket.error'>: [rrno 111] Connection refused)

Just so you know, I referenced this post https://ask.openstack.org/en/question... but it didnt help my particular case.

Here is my ifconfig:

openstack@proxy1:/var/log$ ifconfig 
          em1       Link encap:Ethernet HWaddr f4:6d:04:e3:ee:9e
          inet addr:10.0.0.51  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: fe80::f66d:4ff:fee3:ee9e/64 Scope:Link
          inet6 addr: 2601:9:3580:2bd:f66d:4ff:fee3:ee9e/64 Scope:Global
          inet6 addr: 2601:9:3580:2bd:a5b0:7590:4e60:4660/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:16852 errors:0 dropped:1 overruns:0 frame:0
          TX packets:7958 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:10019357 (10.0 MB)  TX bytes:1057366 (1.0 MB)
          Interrupt:20 Memory:f6600000-f6620000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:64 errors:0 dropped:0 overruns:0 frame:0
          TX packets:64 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:5744 (5.7 KB)  TX bytes:5744 (5.7 KB)

    root@storage1:/var/log# ifconfig 
          lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:12 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1176 (1.1 KB)  TX bytes:1176 (1.1 KB)

p2p1      Link encap:Ethernet  HWaddr 40:16:7e:73:7a:0f
          inet addr:10.0.0.61  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: 2601:9:3580:2bd:4216:7eff:fe73:7a0f/64 Scope:Global
          inet6 addr: 2601:9:3580:2bd:4c5c:9b60:3c65:1909/64 Scope:Global
          inet6 addr: fe80::4216:7eff:fe73:7a0f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:18374 errors:0 dropped:1 overruns:0 frame:0
          TX packets:3441 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:6071968 (6.0 MB)  TX bytes:457307 (457.3 KB)

rsyncd.conf

uid = swift
gid = swift
log file = /var/log/rsyncd.log
pid file = /var/run/rsyncd.pid
address = 10.0.0.61
[account]
max connections = 2
path = /srv/node/
read only = false
lock file = /var ...
(more)
edit retag flag offensive close merge delete

Comments

which logs files would that be? i went looked in /var/log on my controller proxy and storage and didnt find any log file that was helpful

travhoang77 gravatar imagetravhoang77 ( 2015-01-27 04:40:48 -0500 )edit

Swift always logs to syslog. The default facility is local0. So, if you don't do anything, the log ends in /var/log/messages, /var/log/syslog, or such. The convention is to redirect it to /var/log/swift/swift.log in rsyslog.conf. Track that down.

zaitcev gravatar imagezaitcev ( 2015-01-29 13:53:06 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-01-27 04:28:03 -0500

updated 2015-01-27 04:30:07 -0500

Hey hi, first ensure whether your controller is reachable and port 8080 is open. Secondly, please go through the log files to get to know the cause of this error. Thirdly, ensure that all your swift services are up. And, also check whether all the settings in conf file is proper.

edit flag offensive delete link more
1

answered 2015-02-05 08:33:16 -0500

updated 2015-02-05 11:31:49 -0500

smaffulli gravatar image

Hi, You can omit the replication_net_ip in your case. Make sure your entries are added correctly to each ring like this:

# swift-ring-builder account.builder add z1-10.0.0.61:6002/ sdb1 100
# swift-ring-builder container.builder add z1-10.0.0.61:6001/ sdb1 100
# swift-ring-builder object.builder add z1-10.0.0.61:6000/ sdb1 100

There should be space between / and sdb1. Later verify the ring contents for each ring and rebalance the rings.This creates .ring.gz files, copy the account.ring.gz, container.ring.gz, and object.ring.gz files to Storage node in /etc/swift. Type command: chown -R swift:swift /etc/swift Restart the Proxy service. Run the command: swift-init all start Now you can verify the installation :)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-01-27 04:03:12 -0500

Seen: 1,118 times

Last updated: Feb 05 '15