Creating public subnet in devstack's local.conf

asked 2015-01-26 08:56:36 -0500

jslater gravatar image

Hi All,

I've been playing with devstack and can get most things working, but the one issue I'm having with is networking. What I am trying to do is get a config which allocates a small range of ip's on a pre-existing network, 192.168.2.X. I control all of 192.168.2.X but want to limit openstack to, say .190 - .195. My pre-existing router is 192.168.2.1, and I don't want any instances to have their own private 10.X.X.X network. I've tried various options in local.conf after following various online guides but can't get it to work properly.

I have a single network interface, eth0 which is already assigned 192.168.2.155.

My local.conf file looks something like:

[[local|localrc]] ADMIN_PASSWORD=mypassword DATABASE_PASSWORD=$ADMIN_PASSWORD RABBIT_PASSWORD=$ADMIN_PASSWORD SERVICE_PASSWORD=$ADMIN_PASSWORD SERVICE_TOKEN=$ADMIN_PASSWORD

FLAT_INTERFACE=eth0 OFFLINE=True HOST_IP=192.168.2.155

PUBLIC_SUBNET_NAME=public-subnet FLOATING_RANGE=192.168.2.0/24 Q_FLOATING_ALLOCATION_POOL="start=192.168.2.190,end=192.168.2.195" PUBLIC_NETWORK_GATEWAY=192.168.2.1

DEST=/opt/stack LOGFILE=$DEST/logs/stack.sh.log SCREEN_LOG=$DEST/logs/screen

disable_service n-net enable_service q-svc enable_service q-agt enable_service q-dhcp enable_service q-l3 enable_service q-meta enable_service neutron enable_service tempest enable_service n-novnc

When using this config I've noticed that devstack assigns 192.168.2.1 to br-ex, which is obviously very bad - unless I'm mis-reading what PUBLIC_NETWORK_GATEWAY parameter is really used for?

Any ideas on what I need to do to get this up and running?

Thanks in advance!

edit retag flag offensive close merge delete