Ask Your Question
1

stack.sh hangs on git clone to /opt/stack/nova

asked 2015-01-26 01:24:50 -0500

RobP gravatar image

Hi,

I have got a new Ubuntu 14.04 install on a boot partition of a late-2013 iMac, installed as Server, but added xubuntu-desktop.

I have tried many different installs/uninstalls - including unstack.sh and clean.sh and reboots.

Every single time ./stack.sh hangs forever on:

timeout -s SIGINT 0 git clone git://git.openstack.org/openstack/nova.git /opt/stack/nova
Cloning into '/opt/stack/nova'...

If I run the command from the command line as user stack it gets to 99% of Receiving objects and hangs forever.

If I change the command to use http:// instead of git:// it completes, but re-running stack.sh doesn't make progress.

Any ideas what I can do? I can't find where the url is set to edit it to http:.

Here are the steps I've taken:

cloned devstack to /opt/devstack Set up the stack user using /opt/devstack/tools/create_stack-user.sh chown /opt/devstack to stack:stack cd /opt/devstack ./stack.sh

My local.conf:

[[local|localrc]]

# Credentials
ADMIN_PASSWORD=devstack
MYSQL_PASSWORD=devstack
RABBIT_PASSWORD=devstack
SERVICE_PASSWORD=devstack
SERVICE_TOKEN=token

#Enable/Disable Services
disable_service n-net
enable_service q-svc
enable_service q-agt
enable_service q-dhcp
enable_service q-l3 
enable_service q-meta
enable_service neutron
enable_service tempest

HOST_IP=10.163.200.32
FLOATING_RANGE=192.168.1.0/24
PUBLIC_NETWORK_GATEWAY=192.168.1.1
FIXED_RANGE=10.0.0.0/24

#Stable Branches
NOVA_BRANCH=stable/icehouse
CINDER_BRANCH=stable/icehouse
GLANCE_BRANCH=stable/icehouse
HORIZON_BRANCH=stable/icehouse
KEYSTONE_BRANCH=stable/icehouse
NEUTRON_BRANCH=stable/icehouse

#NEUTRON CONFIG
Q_USE_DEBUG_COMMAND=True

#CINDER CONFIG
VOLUME_BACKING_FILE_SIZE=102400M

#GENERAL CONFIG
API_RATE_LIMIT=False

#Output
LOGFILE=/opt/stack/logs/stack.sh.log
VERBOSE=True
LOG_COLOR=False
SCREEN_LOGDIR=/opt/stack/logs

# End local.conf
edit retag flag offensive close merge delete

Comments

any proxies involved? anyway try adding GIT_BASE=http://git.openstack.org to local.conf

darragh-oreilly gravatar imagedarragh-oreilly ( 2015-01-26 13:18:30 -0500 )edit

No proxies involved, but GIT_BASE in the local.conf did the trick! Thanks. Now I'm hanging on "keystone did not start", but I'm pretty sure a little investigation will reveal that that is my fault...

RobP gravatar imageRobP ( 2015-01-27 03:12:14 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
3

answered 2015-01-27 05:59:36 -0500

RobP gravatar image

updated 2015-01-27 06:01:00 -0500

Adding GIT_BASE=http://git.openstack.org to local.conf did the trick.

However, it then failed further on into stack.sh.

Deleting the IP related entries in the above local.conf allowed to complete, and horizon was active.

However, then executing ./exercises.sh caused Neutron related tests to fail, so I've got a little more learning to do, but the GIT_BASE trick definitely solved this problem.

edit flag offensive delete link more
0

answered 2015-09-17 07:43:50 -0500

you can also add GIT_BASE=git://github.com (or GIT_BASE=http://github.com) to local.conf

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-01-26 01:24:50 -0500

Seen: 3,590 times

Last updated: Jan 27 '15