Ask Your Question

Error: Unauthorized on dashboard

asked 2013-10-14 08:22:55 -0500

sngirame gravatar image

updated 2013-10-14 08:27:06 -0500

I have installed grizzly on centOS using the below mentioned documentation-

When I go to dashboard in various work spaces, I get errors like

Error: Unauthorized: Unable to retrieve volume list. Error: Unauthorized: Unable to retrieve volume types Error: Unauthorized: Unable to retrieve quota information.

in httpd log there are multiple occurance of an error [error] Unauthorized: Unauthorized (HTTP 401)

Also in keystone log I see multiple warnings WARNING [keystone.common.wsgi] Authorization failed. The request you have made requires authentication. from

Can anyone please explain what has gone wrong? how to resolve this?

edit retag flag offensive close merge delete


I have already tried solution mentioned at although that did not work.

sngirame gravatar imagesngirame ( 2013-10-14 08:23:33 -0500 )edit

3 answers

Sort by ยป oldest newest most voted

answered 2013-10-16 09:11:53 -0500

sngirame gravatar image

I was able to figure out the issue, The script which was used to populate DB ( ) did not created cinder user account. After adding it , it started working.

edit flag offensive delete link more

answered 2013-10-14 11:08:37 -0500

jpichon gravatar image

Is there a traceback before that error, that may provide more information?

Does this happen for all the panels (Overview, Instances, Volumes, etc...) or only Volumes?

Please check that cinder is up and working correctly (e.g. cinder list from the command line doesn't fail with the same error).

Did you try logging out and back in again?

edit flag offensive delete link more


This error is reported for Overview, volumes,system info, images and snapshots work spaces. The issue doesn't seems to be only dashboard because when I try to create volume from command line ( cinder create) ERROR: Unauthorized is reported there as well & even cinder list command reports ERROR: Unauthorized . Here is a pastebin link for the stack trace shown in httpd log

sngirame gravatar imagesngirame ( 2013-10-14 22:54:15 -0500 )edit

Cinder api log has following error 2013-10-14 05:56:30 WARNING [keystoneclient.middleware.auth_token] Unexpected response from keystone service: {u'error': {u'message': u'The request you have made requires authentication.', u'code': 401, u'title': u'Not Authorized'}}

sngirame gravatar imagesngirame ( 2013-10-14 22:54:46 -0500 )edit

This all points toward an issue with the Cinder (Block Storage) configuration, double check that your configuration files in /etc/cinder/ are correct. Especially auth_strategy and the [keystone_authtoken] section in cinder.conf, and the [filter:authtoken] section in api-paste.ini

jpichon gravatar imagejpichon ( 2013-10-15 03:15:09 -0500 )edit

I have checked are the files Do you see any issues with this configuration?

sngirame gravatar imagesngirame ( 2013-10-15 04:58:11 -0500 )edit

I'm less familiar with Cinder. What I would check: do you actually have a user called 'cinder' , with password 'cinder', that is a member of a tenant/project called 'service'? If not, create it using e.g. the Admin dashboard and Users/Projects. If it still doesn't work, I would also change in the...

jpichon gravatar imagejpichon ( 2013-10-15 05:04:45 -0500 )edit

answered 2014-09-18 11:54:49 -0500

Pankaj gravatar image

updated 2014-09-18 12:15:26 -0500

I hit the same issue and did following to solve:

1) mysql -u root;

2) CREATE USER 'cinder'@'localhost';

3) quit;

After above steps if problem persists : you need to make sure you logout of openstack and login again. If your browser has session valid, you need to invalidate it.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools



Asked: 2013-10-14 08:22:55 -0500

Seen: 12,650 times

Last updated: Sep 18 '14