Ask Your Question

Invalid host 'ip' X-Container-Sync-To

asked 2013-04-29 10:54:00 -0500

jov gravatar image

Hello, I need some help setting up container sync across 2 openstack swift clusters located in different data centres. I try to follow the guide here (

but My problem is that I still get the Invalid host 'ip' X-Container-Sync-To in the node's logs. what I did was allow the allowedsynchosts in the container-server.conf and even try to add it in the source proxy-server.conf

right now I am just interesting on getting one way sync, the testing cluster that I am using has access from the internet including the nodes.

if anyone can give me some insight on how to do this correctly I would appreciate it


edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2013-05-03 12:59:03 -0500

jov gravatar image

Okay I figured it out.. first the allow sync host has to be in every node, and then needs to restart by: swift-init container-sync restart

after that everything started working.


edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2013-04-29 10:54:00 -0500

Seen: 217 times

Last updated: May 03 '13