Ask Your Question

service neutron-server restart stop unknown instance

asked 2015-01-25 21:23:31 -0500

Pulak gravatar image


I installed neutron server and neutron-plugin-ml2 in the compute server. The OS is ubuntu 14.04 LTS and openstack version is Icehouse. I have done all the steps mentioned in the Openstack site, but when I am running the command "service neutron-server stop", I am getting an output as "stop: Unknown instance:". When I am starting the service with the command "service neutron-server start", it is getting started properly. But upon checking the status , I am getting an output as "neutron-server stop/waiting".

I will appreciate if anybody can help me in troubleshooting this issue or if anybody encountered this issue before.

Thanks & regards,


edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2015-01-25 22:24:41 -0500

Pulak gravatar image

I stopped getting this issue now after i removed some extra spaces from ml2_conf.ini file. now neutron-server service is getting started properly.

But now I am getting an issue when running any command with neutron, example, if i am running neutron agent-list, getting an error that "Connection to neutron failed: Maximum attempts reached" and also unable to create any extrenal network, am getting an error as "Connection to neutron failed: [Errno 111] Connection refused".

I will really appreciate any help in this.

Thanks & regards, Pulak

edit flag offensive delete link more


Finally I solved the issue. well, just figured out that it was an issue with the message broker where the password was wrong for the rabbitmq user id. I just changed the password of guest and changed the configuration file according and it started working. Thanks.

Pulak gravatar imagePulak ( 2015-01-25 22:41:25 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools


Asked: 2015-01-25 21:23:31 -0500

Seen: 1,396 times

Last updated: Jan 25 '15