Ask Your Question
0

qpidd on controller?

asked 2015-01-23 03:28:10 -0500

msuchy gravatar image

I deployed RDO Icehouse. I have one controller with eth0 to external network, eth1 to internal network where I plan to add more compute nodes. Controller is basically all-in-one. I am able to create volumes, VM, connect to those VM. Everything perfect.

So I added another machine connected to that private network and configured it as compute node. I followed:

http://docs.openstack.org/icehouse/install-guide/install/yum/content/nova-compute.html
http://docs.openstack.org/icehouse/install-guide/install/yum/content/neutron-ml2-compute-node.html

But my controller does not use that new compute node. On compute node I have:

/var/log/nova/nova-compute.log

full of these lines:

2015-01-23 09:12:21.729 2330 ERROR oslo.messaging._drivers.impl_qpid [-] Unable to connect to AMQP server: [Errno 113] EHOSTUNREACH. Sleeping 5 seconds

The routing itself should be OK as I'm able to:

telnet controller 443

from compute node successfully.

What I see as potentional problem is that on controller there is:

# service qpidd status
Redirecting to /bin/systemctl status  qpidd.service qpidd.service
Loaded: not-found (Reason: No such file or directory)
Active: inactive (dead)

And I could not find any documentation that I should configure qpidd on controller . Well. I find this: https://openstack.redhat.com/Securing... but that is just about hardening. But I could not find anything about initial config.

Did I miss something?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
2

answered 2015-01-23 04:29:31 -0500

dbaxps gravatar image

Use as comment field . Attempt on Controller

  $ yum install qpid-cpp-server -y
  $ sed -i 's/auth=.*/auth=no/g' /etc/qpid/qpidd.conf
  $ grep auth /etc/qpid/qpidd.conf 
  auth=no
  # Start and enable qpidd.service
  $ for i in start enable status; \
    do systemctl $i qpidd; done
edit flag offensive delete link more

Comments

Thank, using this strings I was able to locate the part of OpenStack documentation. It is http://docs.openstack.org/icehouse/in... which I missed.

msuchy gravatar imagemsuchy ( 2015-01-23 04:58:29 -0500 )edit
0

answered 2015-01-23 05:12:43 -0500

Seem that there is a problem with your qpid on controller node. Check if the basic options in the installation manual are OK and the service running properly. You can see this guide about qpid on Openstack for more information. link text

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-01-23 03:28:10 -0500

Seen: 252 times

Last updated: Jan 23 '15