Ask Your Question
2

CentOS 6.4 Swift Proxy start

asked 2013-10-12 05:25:00 -0500

Ken B. gravatar image

updated 2013-10-12 14:11:51 -0500

sgordon gravatar image

Has anyone seen this error when trying to start a proxy server right after a fresh install/setup of Swift?

Error trying to load config from /etc/swift/proxy-server.conf: xattr>=0.4

I am not sure why the yum install commands pulled down such old versions of swift (see below). I have been working on Ubuntu and this is my first dance with CentOS. It's also python 2.6.

$ rpm -q -a |grep openstack
openstack-swift-object-1.10.0-0.1.rc1.el6.noarch
kernel-headers-2.6.32-358.118.1.openstack.el6.x86_64
openstack-swift-plugin-swift3-1.0.0-0.20120711git.el6.noarch
openstack-swift-container-1.10.0-0.1.rc1.el6.noarch
openstack-utils-2013.2-1.el6.1.noarch
openstack-swift-1.10.0-0.1.rc1.el6.noarch
openstack-swift-proxy-1.10.0-0.1.rc1.el6.noarch
openstack-swift-account-1.10.0-0.1.rc1.el6.noarch
edit retag flag offensive close merge delete

Comments

What repository are you getting OpenStack packages from? It looks like you have the Havana version of openstack-utils but as you note very old Swift packages.

sgordon gravatar imagesgordon ( 2013-10-12 15:50:09 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2013-10-16 20:42:53 -0500

Ken B. gravatar image

Thank you. That was it. The docs I was following was not updated for grizzly. I created the following .repo file in /etc/yum.repos.d and was able to pull down 1.8 versions swift for Grizzly. CentOS was pretty painless to install once I got the more recent versions.

Place this file in your /etc/yum.repos.d/ directory

[epel-openstack-grizzly] name=OpenStack Grizzly Repository for EPEL 6 baseurl=http://repos.fedorapeople.org/repos/openstack/openstack-grizzly/epel-6 enabled=1 skip_if_unavailable=1 gpgcheck=0 priority=98 ~

edit flag offensive delete link more
0

answered 2013-10-17 12:50:27 -0500

mkollaro gravatar image

This isn't because you have an old version of Swift. The version 1.10 comes after 1.9. This is bug somewhere in the packaging of Swift, I've already opened a bug for this: https://bugzilla.redhat.com/show_bug.cgi?id=1020449

Maybe you could work around it by installing xattr (not the same as pyxattr).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-10-12 05:25:00 -0500

Seen: 378 times

Last updated: Oct 17 '13