Ask Your Question
2

Is possible create public network without floating ip?

asked 2015-01-22 02:42:19 -0500

iqbal gravatar image

updated 2015-01-22 02:42:34 -0500

Dear Stackers,

Is possible to create public network without floating ip,

I have lan network: 192.168.100.0/24

i want my instance have 2 eth

eth0 (private network): 10.8.8.0/24

eth1 (public ip that connect to my lan network): 192.168.100.0/24

I use neutron flat network and gre

Thank you

edit retag flag offensive close merge delete

Comments

Have you tried the provider flat network options while creating network. I think using that it's possible

Ranjit gravatar imageRanjit ( 2015-01-22 03:03:53 -0500 )edit

Dear Ranjit,

Yes i tried, but flat network only can be used for floating ip, when i used flat network directly instance failed to create

iqbal gravatar imageiqbal ( 2015-01-22 03:06:35 -0500 )edit

Some time back, i had followed this link https://developer.rackspace.com/blog/... to setup flat network and able to assign ip on VM's eth0 from LAN network(in your case 192.168.100.0/24) . Try it.

Ranjit gravatar imageRanjit ( 2015-01-22 04:16:12 -0500 )edit

Dear Ranjit,

I try follow the given link, but still not working. I can't build an instance and the network::dhcp ip can't be ping from my lan. Btw i use ml2 plugin

Have any idea??

Thank you

iqbal gravatar imageiqbal ( 2015-01-22 05:03:35 -0500 )edit

iqbal, Need below info.

  1. output of ovs-vsctl show
  2. Neutron.conf and ml2 related conf
  3. neutron net-list
  4. neutron subnet-list
Ranjit gravatar imageRanjit ( 2015-01-22 06:43:58 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-01-22 12:59:04 -0500

iqbal gravatar image

Dear Ranjit,

Thank you so much for your help, really appreciate that.

I already solve the issue, so must add ovs bridge at network node and compute node. I just add it on network node only, now everything is working...

Thank you so much

edit flag offensive delete link more
1

answered 2015-01-22 09:07:24 -0500

iqbal gravatar image

Dear Ranjit,

This is the network node configuration

ovs-vsctl show

root@network1:/etc/init.d# ovs-vsctl show
61204daf-b22c-4066-a964-330ca04d80fd
    Bridge br-tun
        Port "gre-c0a8642d"
            Interface "gre-c0a8642d"
                type: gre
                options: {df_default="true", in_key=flow, local_ip="192.168.100.44", out_key=flow, remote_ip="192.168.100.45"}
        Port "gre-0a0a0a66"
            Interface "gre-0a0a0a66"
                type: gre
                options: {df_default="true", in_key=flow, local_ip="192.168.100.44", out_key=flow, remote_ip="10.10.10.102"}
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
        Port "gre-7f000001"
            Interface "gre-7f000001"
                type: gre
                options: {df_default="true", in_key=flow, local_ip="192.168.100.44", out_key=flow, remote_ip="127.0.0.1"}
        Port br-tun
            Interface br-tun
                type: internal
        Port "gre-c0a86430"
            Interface "gre-c0a86430"
                type: gre
                options: {df_default="true", in_key=flow, local_ip="192.168.100.44", out_key=flow, remote_ip="192.168.100.48"}
        Port "gre-0a0a0a65"
            Interface "gre-0a0a0a65"
                type: gre
                options: {df_default="true", in_key=flow, local_ip="192.168.100.44", out_key=flow, remote_ip="10.10.10.101"}
    Bridge "br-eth2"
        Port "br-eth2"
            Interface "br-eth2"
                type: internal
        Port "phy-br-eth2"
            Interface "phy-br-eth2"
                type: patch
                options: {peer="int-br-eth2"}
        Port "eth2"
            Interface "eth2"
    Bridge br-int
        fail_mode: secure
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port "tapd296662e-42"
            tag: 4
            Interface "tapd296662e-42"
                type: internal
        Port "qr-7e511604-79"
            tag: 4095
            Interface "qr-7e511604-79"
                type: internal
        Port "qr-fdc0c256-8c"
            tag: 4095
            Interface "qr-fdc0c256-8c"
                type: internal
        Port br-int
            Interface br-int
                type: internal
        Port "int-br-eth2"
            Interface "int-br-eth2"
                type: patch
                options: {peer="phy-br-eth2"}
    ovs_version: "2.1.0"

/etc/neutron/neutron.conf

[DEFAULT]
verbose = True
network_device_mtu=1454
lock_path = $state_path/lock
core_plugin = neutron.plugins.ml2.plugin.Ml2Plugin
service_plugins = neutron.services.l3_router.l3_router_plugin.L3RouterPlugin
auth_strategy = keystone
allow_overlapping_ips = True
dhcp_agents_per_network = 2
rabbit_hosts = controller1.bms-cloud.lan,controller2.bms-cloud.lan
rabbit_userid = guest
rabbit_password = opensource
rpc_backend=rabbit
[matchmaker_redis]
[matchmaker_ring]
[quotas]
[agent]
root_helper = sudo neutron-rootwrap /etc/neutron/rootwrap.conf
[keystone_authtoken]
auth_uri = http://controller.bms-cloud.lan:5000/v2.0
identity_uri = http://controller.bms-cloud.lan:35357
auth_host = controller.bms-cloud.lan
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = service
admin_password = opensource
[database]
connection = mysql://neutron:opensource@controller.bms-cloud.lan/neutron
[service_providers]
service_provider=VPN:openswan:neutron.services.vpn.service_drivers.ipsec.IPsecVPNDriver:default

/etc/neutron/plugins/ml2/ml2_conf.ini

[ml2]
type_drivers = flat,gre,local,vlan
tenant_network_types = gre
mechanism_drivers = openvswitch
[ml2_type_flat]
flat_networks = *
[ml2_type_vlan]
network_vlan_ranges = physnet1:1:1000
[ml2_type_gre]
tunnel_id_ranges = 1:1000
[ml2_type_vxlan]
[securitygroup]
enable_security_group = True
enable_ipset = True
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
[ovs]
local_ip = 192.168.100.44
tunnel_type = gre
enable_tunneling = True
network_vlan_ranges = physnet1:1:1000
bridge_mappings = physnet1:br-eth2
[agent]
tunnel_types = gre

network detail

+---------------------------+--------------------------------------+
| Field                     | Value                                |
+---------------------------+--------------------------------------+
| admin_state_up            | True                                 |
| id                        | c7bbcd5e-51f8-4932-ba1b-e3da243e59c0 |
| name                      | ext-net                              |
| provider:network_type     | flat                                 |
| provider:physical_network | physnet1                             |
| provider:segmentation_id  |                                      |
| router:external           | False                                |
| shared                    | True                                 |
| status                    | ACTIVE                               |
| subnets                   | 5e2e1758-2feb-4506-8a0c-364778257251 |
| tenant_id                 | 25469125c32d419891bae312890d206a     |
+---------------------------+--------------------------------------+

subnet detail

+-------------------+------------------------------------------------------+
| Field             | Value                                                |
+-------------------+------------------------------------------------------+
| allocation_pools  | {"start": "192.168.100.53", "end": "192.168.100.60"} |
| cidr              | 192.168.100.0/24                                     |
| dns_nameservers   |                                                      |
| enable_dhcp       | True                                                 |
| gateway_ip        |                                                      |
| host_routes       |                                                      |
| id                | 5e2e1758-2feb-4506-8a0c-364778257251                 |
| ip_version        | 4                                                    |
| ipv6_address_mode |                                                      |
| ipv6_ra_mode      |                                                      |
| name              | ext-subnet                                           |
| network_id        | c7bbcd5e-51f8-4932-ba1b-e3da243e59c0                 |
| tenant_id         | 25469125c32d419891bae312890d206a                     |
+-------------------+------------------------------------------------------+
edit flag offensive delete link more

Comments

iqbal, sorry to say i asked some information but i might not able to help. Because your setup is multi-node setup and the i used the provided link for single node. (all service in one node)

Ranjit gravatar imageRanjit ( 2015-01-22 10:13:46 -0500 )edit

If you are able to fix, then let me know also. Have a look https://community.rackspace.com/produ...

Ranjit gravatar imageRanjit ( 2015-01-22 10:14:51 -0500 )edit

Dear Ranjit,

It's ok, everything work fine if I use floating IP and gre tunneling,

But the problem is I want install keepalived for listen public network,

Is that possible for listening floating IP, because i tried and fail..

Thank you

iqbal gravatar imageiqbal ( 2015-01-22 11:17:16 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-01-22 02:42:19 -0500

Seen: 1,051 times

Last updated: Jan 22 '15