Dashboard Problem with URL of VNC Console

asked 2015-01-21 13:47:23 -0500

AlanObject gravatar image

I run openstack-dashboard in a VM based on Ubuntu 12.04 separate from the rest of the OpenStack components. It was very easy to install and get working except for this one problem.

When attempting to attach to the VNC console of some VM instance, the URL is formed with the hostname of the OS controller. So I get a URL that looks like this:

http://osccontrol:6080/ ...

If I manually replace the string with the IP address of the control system, it then works, like this: ...

What is the best way to fix this? Can dashboard be configured to form the URL with the IP address or is there a way to associate a DNS name with the system known as oscontrol?

OpenStack release is Icehouse.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2015-01-22 00:10:17 -0500

These are the options you can configure for vnc.

# Change vncserver_proxyclient_address and vncserver_listen to match each compute host

In nova.conf change vnc_proxyclient_address to your IP address and the restart nova-compute service.

edit flag offensive delete link more



Make sure you do this on the compute nodes, not the controller. A quick way to check is to do "console show url" from cli, as this will change on the existing VMs, not just new ones.

arbcat gravatar imagearbcat ( 2018-03-17 03:26:24 -0500 )edit

I resolved that with only setting novncproxy_base_url. As arbcat mentioned: on the computes nodes, NOT the controller!

ICBeter gravatar imageICBeter ( 2018-07-26 11:13:21 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2015-01-21 13:47:23 -0500

Seen: 1,905 times

Last updated: Jan 22 '15