What are the specific settings to disable Keystone endpoint discovery?

asked 2015-01-21 10:09:27 -0500

JustcallmeDrago gravatar image

The first time I run a heat command (such as heat stack-list) after the heat-api service starts, it has the keystonemiddleware make requests to identity. I am supplying every setting I can find to try to get the keystonemiddleware to not do autodiscovery (since the json identity returns is not formatted how it expects) but for some reason I cannot turn it off. What are the settings to do so?

I am using the current master of Heat (https://github.com/openstack/heat/tree/f690f8d599002f920da96c342ed1b2ff8eff8a93 (f690f8d599002f920da96c342ed1b2ff8eff8a93))

Settings I am trying so far:

  • Heat.conf

    • [DEFAULT]
      • keystone_backend="heat.engine.plugins.heat_keystoneclient_v2.client.KeystoneClientV2"
    • [keystone_authtoken]
      • auth_uri = https://MyIdentityIP/v2.0/
      • auth_version = v2.0
      • identity_uri = https://MyIdentityIP/
      • auth_port = 443
      • auth_protocol = https
  • openrc (which I do source openrc before running heat-api)

    • export OS_AUTH_URL=https://MyIdentityIP/v2.0/
edit retag flag offensive close merge delete