Ask Your Question
0

windows 2012 vm stuck in "Getting Ready"

asked 2015-01-21 08:04:37 -0500

schegi gravatar image

updated 2015-01-24 06:13:24 -0500

Hi,

currently go some problems to get a windows_server_2012_R2 vm running. I tested two different images, one created according to the description in the http://docs.openstack.org/image-guide/content/windows-image.html (openstack docs) and the other one was downloaded directly from http://www.cloudbase.it/ws2012r2/ (here).

Starting the vm from images is not the problem, i can get a console via horizon showing me the first boot process but during that process the machine hangs with "Getting Ready" and an opened shell showing debug outpute from cloudbase-init.exe

The only log under C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-Init\log\ is cloudbase-init-unattended.log and it shows no errors. Unfortunately i could not copy/paste content from the remote console and do not have the points to provide a screenshot. Here is the last entry of the log:

DEBUG cloudbaseinit.metadata.services.httpservice [-] Getting data from: http://169.254.169.254/openstack/lates/meta_data.json (http://169.254.169.254/openstack/late...) _get_data C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-Init\Python27\lib\site-packages\cloudbaseinit\metadata\services\httpservice.py:68

So i first thought it has something to do with getting the metadata. But opening another shell with shift+F10 is possible and it shows me that network is up. The metadataserver at 169.254.169.254 is reachable (Invoke-WebRequest -OutFile test http://169.254.169.254.169/openstack/lates/meta_data.json (http://169.254.169.254.169/openstack/...) resturns the expected).

Anybody solved this issue or had any idea / recommendation, regarding the source or other logs which could provide additional information on what is going wrong?

Thx Stefan

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2015-01-24 06:10:40 -0500

schegi gravatar image

updated 2015-01-25 07:27:54 -0500

Hi, another solution. Found this question here

http://ask.cloudbase.it/question/232/openstack-launch-instance-hangs-on-getting-metadata/?answer=258#post-id-258 (http://ask.cloudbase.it/question/232/...)

I am using GRE tunnels in my setup, so this lead me to investigate the mtu using

netsh interface ipv4 show interfaces

It was set to 1500. It seems that windows ignores mtu information provided by the dhcp server. Did not found any solution how to enable this. So i decided to set it manually to 1458, using

netsh interface ipv4 set subinterface "Ethernet" mtu=1458 store=persistent

This seems to solve the problem even with provided key-pair. I will now try to build an windows image with preset mtu of 1458.

Edit: Ok, I builded a windows server 2012 R2 image following the official openstack http://docs.openstack.org/image-guide/content/windows-image.html (documentation) and before 7.) running cloudbasinit.msi, I set the mtu of interface Ethernet to 1458 by

netsh interface ipv4 set subinterface "Ethernet" mtu=1458 store=persistent

With the so build image everything works fine. First boot succeeds, Webaccess from an instanced created from this image works fine. Stefan

edit flag offensive delete link more
2

answered 2015-01-21 08:14:59 -0500

zsolt-krenak gravatar image

Hi!

I had the exact same issue with the cloudbase image when I was testing Windows a few weeks back. I didn't find a real solution, but I found a workaround really quickly, so I stopped looking for one

For me the workaround was to not assign a private key, when launching a windows instance. This way it could boot up. Then I used the noVNC console to setup an administrator account(I think the cloudbase version doesn't have a password for administrator at first boot up, but when you try to login it asks for creating one). After this everything worked as expected.

I hope this can help you, although it isn't a real solution.

edit flag offensive delete link more

Comments

Thx for the quick reply, leaving out the keypair in the dashboard seems to solve the issue. I will write a bugreport on cloudbase.

schegi gravatar imageschegi ( 2015-01-21 08:28:06 -0500 )edit

i hit the same issue. not assigning private key to the server solve the problem. is it possible for us to disable private key inside the cloudbase cloud-init itself?

senyapsudah gravatar imagesenyapsudah ( 2015-08-15 19:01:13 -0500 )edit
0

answered 2018-10-09 09:56:17 -0500

Establish a link with your disconnected NICs. This "problem" goes as far back as SBS 2000 or 2003, AFAI remember.

If you're an integration house or system builder, keep a cheap powered-on switch nearby. It doesn't need a connection to anything. It just needs a link status of not disconnected.

danielkr

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-01-21 08:04:37 -0500

Seen: 3,801 times

Last updated: Jan 25 '15