Ask Your Question
0

500 server error

asked 2015-01-21 04:16:06 -0500

sagar gravatar image

updated 2015-01-21 07:16:00 -0500

Hello all

i am getting following error when executing swift command

swift -A http://localhost:8080/auth/v1.0 -U testaccount:tester -K testing stat
Auth GET failed: http://localhost:8080/auth/v1.0/ 500 Server Error

Please help me what is the problem

thanks in advance

kalasagar

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-01-22 01:20:43 -0500

sagar gravatar image

i rebooted machine again . surprisingly i got new error message

Auth GET failed: http://127.0.0.1:8080/auth/v1.0/ 401 Unauthorized

what s going on please guide me.

edit flag offensive delete link more
0

answered 2015-01-21 14:33:23 -0500

Swift service can not authenticate your request via keystone, due to miss-configuration or lack of connectivity to keystone server. Check your swift log to find a clue of what was exactly happened?

Swift Log file:

/var/log/swift
edit flag offensive delete link more

Comments

i found some error messages in /var/log/syslog

Starting object replication pass. object-replicator: Exception in top-level replication loop: [Errno 5] Input/output error: '/srv/3/node/sdb3/tmp' object-replicator: Nothing replicated for 0.000484943389893.

its showing for all 4 sdbs

sagar gravatar imagesagar ( 2015-01-21 22:18:27 -0500 )edit

before system reboot its working fine. I rebooted system and started swift services

After that its not working

sagar gravatar imagesagar ( 2015-01-21 22:22:11 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-01-21 04:16:06 -0500

Seen: 229 times

Last updated: Jan 21 '15