Ask Your Question
1

Creating glance image 403 forbidden access

asked 2015-01-21 03:22:30 -0600

shadow gravatar image

updated 2015-01-22 07:44:43 -0600

I am trying to create an image on my openstack installation with this commande :

glance image-create --name "cirros-0.3.3-x86_64" --disk-format qcow2 --container-format bare -is-public true --progress <cirros-0.3.3-x86_64-disk.img< p="">

but I am getting an error message in html :

<html><head><title>403 forbidden access</title>...

I have check my log file registry log file i have found this :

2015-01-20 17:52:08.794 2579 INFO glance.wsgi.server [-] Removing dead child 2585 2015-01-20 17:52:08.796 2579 INFO glance.wsgi.server [-] Started child 2671 2015-01-20 17:52:08.797 2579 DEBUG glance.wsgi.server [-] Exited wait_on_children /usr/lib/python2.7/dist-packages/glance/common/wsgi.py:300 2015-01-20 17:52:08.802 2671 INFO glance.wsgi.server [-] (2671) wsgi starting up on http://0.0.0.0:9292/ 2015-01-20 17:52:08.803 2671 INFO glance.wsgi.server [-] Child 2671 exiting normally 2015-01-20 17:52:09.149 2673 ERROR glance_store._drivers.filesystem [-] Specify either 'filesystem_store_datadir' or 'filesystem_store_datadirs' option 2015-01-20 17:52:09.150 2673 WARNING glance_store.driver [-] Failed to configure store correctly: None Disabling add method. 2015-01-20 17:52:09.150 2673 ERROR glance_store._drivers.filesystem [-] Specify either 'filesystem_store_datadir' or 'filesystem_store_datadirs' option 2015-01-20 17:52:09.151 2673 WARNING glance_store.driver [-] Failed to configure store correctly: None Disabling add method. 2015-01-20 18:07:52.719 2931 ERROR glance_store._drivers.filesystem [-] Specify either 'filesystem_store_datadir' or 'filesystem_store_datadirs' option 2015-01-20 18:07:52.720 2931 WARNING glance_store.driver [-] Failed to configure store correctly: None Disabling add method. 2015-01-20 18:07:52.720 2931 ERROR glance_store._drivers.filesystem [-] Specify either 'filesystem_store_datadir' or 'filesystem_store_datadirs' option 2015-01-20 18:07:52.721 2931 WARNING glance_store.driver [-] Failed to configure store correctly: None Disabling add method.

I have already set the filesystem_store_datadir in the config files but I don't understand why it keep showing me this error ?

Update : I have fixed that was a account policy issue I have just remove the --is-public-true option and it works perfectly but I can't find how to setup my account policy?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-01-22 16:06:22 -0600

MarkE gravatar image

Check the permissions on the folder, they should be glance:glance with RW

edit flag offensive delete link more
0

answered 2015-01-21 06:38:19 -0600

Dear Shadow, what is that you have assigned to filesystem_store_datadir in glance-api.conf

Read the Filesystem Store Options section in the glance-api.conf, it should contain this

filesystem_store_datadir = /var/lib/glance/images/

There can be multiple filesystem_store_datadirs and accordingly priority number may be given after each directory entry, separated by a ":".

edit flag offensive delete link more

Comments

Think you for you response, I have already assigned the file system store option in the glance-api.conf exactly with the same path /var/lib/glance/images/ but it steel showing this error message Could'it be a permission issue?

shadow gravatar imageshadow ( 2015-01-21 08:17:56 -0600 )edit

Dear Shadow, I think you have specified both filesystem_store_datadir and filesystem_store_datadirs options in glance-api.conf file. So, make sure you have one option specified in the glance-api.conf.

Yashpal Beppurana gravatar imageYashpal Beppurana ( 2015-01-25 04:09:59 -0600 )edit

have this issue been resolved?

Scott Zhang gravatar imageScott Zhang ( 2015-05-26 16:31:15 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-01-21 03:22:30 -0600

Seen: 2,323 times

Last updated: Jan 22 '15