Ask Your Question
3

How to change the polling period of ceilometer?

asked 2013-10-10 16:09:17 -0500

cloud gravatar image

updated 2013-10-11 17:30:50 -0500

smaffulli gravatar image

Hello, the default polling period for ceilometer is 10 mins. I want to change it. Can any body help me in this regards? Thank you

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
6

answered 2013-10-12 14:08:34 -0500

sgordon gravatar image

updated 2013-10-17 12:25:40 -0500

Edit the interval values in the /etc/ceilometer/pipeline.yaml file. The interval values are specified in seconds, so 600 seconds is 10 minutes. You may need to restart the Ceilometer service for the change to take effect.

In the default pipeline.yaml file the interval value for the meter_pipeline sets the default interval for all meters (as indicated by setting meters to * in the corresponding block).

The interval value is then repeated for the cpu_pipeline, which is included in the file so that some additional settings related to the transformation of the cpu meter can be supplied. A full list of available meters is available in the documentation at http://docs.openstack.org/developer/ceilometer/measurements.html

---
-
    name: meter_pipeline
    interval: 600
    meters:
        - "*"
    transformers:
    publishers:
        - rpc://
-
    name: cpu_pipeline
    interval: 600
    meters:
        - "cpu"
    transformers:
        - name: "rate_of_change"
          parameters:
              target:
                  name: "cpu_util"
                  unit: "%"
                  type: "gauge"
                  scale: "100.0 / (10**9 * (resource_metadata.cpu_number or 1))"
    publishers:
        - rpc://
edit flag offensive delete link more

Comments

sgordon, Thank you for your reply. However can you please shed some light on this (related to polling period) name: meter_pipeline interval: 60 meters: - "*" transformers: publishers: - rpc:// - name: cpu_pipeline interval: 60 meters: - "cpu" There are two interval. which interval is for what?

cloud gravatar imagecloud ( 2013-10-17 12:09:25 -0500 )edit

I have updated my answer, but the TL;DR; is that one sets the global default and one sets the interval for a specific meter.

sgordon gravatar imagesgordon ( 2013-10-17 12:26:27 -0500 )edit

sgordon what is the command to restart ceilometer services? I changed the interval values in pipeline.yaml but don't know how to make them active. I am using Openstack Liberty on Ubuntu 14.04. Thanks

gh0st1986 gravatar imagegh0st1986 ( 2016-09-30 02:01:15 -0500 )edit

Here's an example from the installation guide, you may need to modify on 14.04 as I can not recall if it was still using upstart or not: http://docs.openstack.org/project-ins...

sgordon gravatar imagesgordon ( 2016-11-09 17:20:01 -0500 )edit
0

answered 2017-03-16 07:08:08 -0500

DarkKnight gravatar image

This is not an answer, but could not include such big contents in the comment.

So, the question is here is my pipeline.yaml file,

[root@controller ~]# cat /etc/ceilometer/pipeline.yaml
---
sources:
    - name: meter_source
      interval: 60
      meters:
          - "*"
      sinks:
          - meter_sink
    - name: cpu_source
      interval: 60
      meters:
          - "cpu"
      sinks:
          - cpu_sink
          - cpu_delta_sink
    - name: disk_source
      interval: 60
      meters:
          - "disk.read.bytes"
          - "disk.read.requests"
          - "disk.write.bytes"
          - "disk.write.requests"
          - "disk.device.read.bytes"
          - "disk.device.read.requests"
          - "disk.device.write.bytes"
          - "disk.device.write.requests"
      sinks:
          - disk_sink

    - name: network_source
      interval: 60
      meters:
          - "network.incoming.bytes"
          - "network.incoming.packets"
          - "network.outgoing.bytes"
          - "network.outgoing.packets"
      sinks:
          - network_sink
sinks:
    - name: meter_sink
      transformers:
      publishers:
          - notifier://
    - name: cpu_sink
      transformers:
          - name: "rate_of_change"
            parameters:
                target:
                    name: "cpu_util"
                    unit: "%"
                    type: "gauge"
                    scale: "100.0 / (10**9 * (resource_metadata.cpu_number or 1))"
      publishers:
          - notifier://
    - name: cpu_delta_sink
      transformers:
          - name: "delta"
            parameters:
                target:
                    name: "cpu.delta"
                growth_only: True
      publishers:
          - notifier://
    - name: disk_sink
      transformers:
          - name: "rate_of_change"
            parameters:
                source:
                    map_from:
                        name: "(disk\\.device|disk)\\.(read|write)\\.(bytes|requests)"
                        unit: "(B|request)"
                target:
                    map_to:
                        name: "\\1.\\2.\\3.rate"
                        unit: "\\1/s"
                    type: "gauge"
      publishers:
          - notifier://
    - name: network_sink
      transformers:
          - name: "rate_of_change"
            parameters:
                source:
                   map_from:
                       name: "network\\.(incoming|outgoing)\\.(bytes|packets)"
                       unit: "(B|packet)"
                target:
                    map_to:
                        name: "network.\\1.\\2.rate"
                        unit: "\\1/s"
                    type: "gauge"
      publishers:
          - notifier://

Here the interval is 60 sec for all metrics, but when i do a ceilometer sample-list, it gives me an o/p not consistent with the setting here.

[root@controller ~]# ceilometer sample-list --query resource=30658d79-03ca-4720-ba43-cc872043e7fa --meter=cpu_util
+--------------------------------------+----------+-------+---------------+------+----------------------------+
| Resource ID                          | Name     | Type  | Volume        | Unit | Timestamp                  |
+--------------------------------------+----------+-------+---------------+------+----------------------------+
| 30658d79-03ca-4720-ba43-cc872043e7fa | cpu_util | gauge | 85.1878115642 | %    | 2017-03-16T11:48:40.941000 |
+--------------------------------------+----------+-------+---------------+------+----------------------------+

Can someone explain this?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-10-10 16:09:17 -0500

Seen: 3,232 times

Last updated: Mar 16