Ask Your Question
0

What I am supposed to tune in cinder to get libgfapi working , providing direct acces Qemu to glusterfs volumes on Juno ?

asked 2015-01-20 00:51:31 -0500

s.laskin gravatar image

Implementing gluster backend for Cinder, finally I watch fuse mounts on compute nodes running VMs with gluster backend. I realize , that presence of glusterfs-fuse mounts on compute node means , that libgfapi is not working for me, it just old "good" schema.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-01-22 06:18:02 -0500

dbaxps gravatar image

Placing qemu_allowed_storage_drivers=gluster is not enough

The following configuration changes are necessary for 'qemu' and '
samba vfs plugin' integration with libgfapi to work seamlessly:

1. First step
       gluster volume set cinder-volumesXX  server.allow-insecure on
2. Restarting is required
    gluster volume stop cinder-volumesXX
    gluster volume start cinder-volumesXX
3. Edit /etc/glusterfs/glusterd.vol   to have a line :
    option rpc-auth-allow-insecure on
4. Restart glusterd is required :
     service glusterd restart
edit flag offensive delete link more

Comments

Yes, now I got dumpxml of instance containing "protocol:gluster"

s.laskin gravatar images.laskin ( 2015-01-22 07:09:35 -0500 )edit
0

answered 2015-01-22 00:46:37 -0500

Did you configured nova to use "libgfapi". To do that we need to put below configuration in "DEFAULT" block of nova.conf:

qemu_allowed_storage_drivers=gluster

And restart nova and test it.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-01-20 00:51:31 -0500

Seen: 413 times

Last updated: Jan 22 '15