Ask Your Question
0

Unable to create a node using ironic node-create

asked 2015-01-19 05:58:46 -0500

Manab gravatar image

updated 2015-01-19 10:40:19 -0500

rbowen gravatar image

Hi When i am using "ironic node-create -d pxe_ipmitool" , getting output as "HTTPResponse instance has no attribute 'text' ". When i checked the logs, found some error in keystone as follows:

2015-01-12 01:49:17.730 1744 ERROR keystonemiddleware.auth_token [-] HTTP connection exception: [SSL: UNKNOWN_PROTOCOL] unknown protocol (_ssl.c:581)
2015-01-12 01:49:17.731 1744 WARNING keystonemiddleware.auth_token [-] Authorization failed for token
2015-01-12 03:53:01.530 1744 WARNING keystonemiddleware.auth_token [-] Retrying on HTTP connection exception: [SSL: UNKNOWN_PROTOCOL] unknown protocol (_ssl.c:581)
2015-01-12 03:53:02.054 1744 WARNING keystonemiddleware.auth_token [-] Retrying on HTTP connection exception: [SSL: UNKNOWN_PROTOCOL] unknown protocol (_ssl.c:581)
2015-01-12 03:53:03.078 1744 WARNING keystonemiddleware.auth_token [-] Retrying on HTTP connection exception: [SSL: UNKNOWN_PROTOCOL] unknown protocol (_ssl.c:581)
2015-01-12 03:53:05.102 1744 ERROR keystonemiddleware.auth_token [-] HTTP connection exception: [SSL: UNKNOWN_PROTOCOL] unknown protocol (_ssl.c:581)
2015-01-12 03:53:05.102 1744 WARNING keystonemiddleware.auth_token [-] Authorization failed for token
2015-01-12 03:53:17.314 1744 WARNING keystonemiddleware.auth_token [-] Retrying on HTTP connection exception: [SSL: UNKNOWN_PROTOCOL] unknown protocol (_ssl.c:581)
2015-01-12 03:53:17.835 1744 WARNING keystonemiddleware.auth_token [-] Retrying on HTTP connection exception: [SSL: UNKNOWN_PROTOCOL] unknown protocol (_ssl.c:581)
2015-01-12 03:53:18.854 1744 WARNING keystonemiddleware.auth_token [-] Retrying on HTTP connection exception: [SSL: UNKNOWN_PROTOCOL] unknown protocol (_ssl.c:581)
2015-01-12 03:53:20.872 1744 ERROR keystonemiddleware.auth_token [-] HTTP connection exception: [SSL: UNKNOWN_PROTOCOL] unknown protocol (_ssl.c:581)
2015-01-12 03:53:20.872 1744 WARNING keystonemiddleware.auth_token [-] Authorization failed for token
2015-01-15 22:28:10.607 1887 WARNING keystonemiddleware.auth_token [-] Configuring admin URI using auth fragments. This is deprecated, use 'identity_uri' instead.
2015-01-15 22:33:46.117 1866 WARNING keystonemiddleware.auth_token [-] Configuring admin URI using auth fragments. This is deprecated, use 'identity_uri' instead.
2015-01-15 22:38:59.080 1897 WARNING keystonemiddleware.auth_token [-] Configuring admin URI using auth fragments. This is deprecated, use 'identity_uri' instead.
2015-01-15 23:00:57.680 1980 WARNING keystonemiddleware.auth_token [-] Configuring admin URI using auth fragments. This is deprecated, use 'identity_uri' instead.
2015-01-16 00:37:23.975 1894 WARNING keystonemiddleware.auth_token [-] Configuring admin URI using auth fragments. This is deprecated, use 'identity_uri' instead.
2015-01-16 03:38:55.543 1911 WARNING keystonemiddleware.auth_token [-] Configuring admin URI using auth fragments. This is deprecated, use 'identity_uri' instead.
2015-01-16 03:49:28.234 1911 WARNING keystonemiddleware.auth_token [-] Retrying on HTTP connection exception: [SSL: UNKNOWN_PROTOCOL] unknown protocol (_ssl.c:581)
2015-01-16 03:49:28.758 1911 WARNING keystonemiddleware.auth_token [-] Retrying on HTTP connection exception: [SSL: UNKNOWN_PROTOCOL] unknown protocol (_ssl.c:581)
2015-01-16 03:49:29.782 1911 WARNING keystonemiddleware.auth_token [-] Retrying on HTTP connection exception: [SSL: UNKNOWN_PROTOCOL] unknown protocol (_ssl.c:581)
2015-01-16 03:49:31.805 1911 ERROR keystonemiddleware.auth_token [-] HTTP connection exception: [SSL: UNKNOWN_PROTOCOL] unknown protocol (_ssl.c:581)
2015-01-16 03:49:31.805 1911 WARNING keystonemiddleware.auth_token [-] Authorization failed for token
2015-01-18 21:31:43.644 6287 WARNING keystonemiddleware.auth_token [-] Configuring admin URI using auth fragments. This is deprecated, use 'identity_uri' instead.
2015-01-18 21:35:06.156 6287 ...
(more)
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-01-29 23:22:28 -0500

Manab gravatar image

Thanks Heiko Your suggetstion workds for me. Thanks a lot

edit flag offensive delete link more
1

answered 2015-01-19 11:10:07 -0500

foexle gravatar image

Hi,

check the connection to Keystone. You have a problem with the authentication process of ironic. You try to use https but i think your Keystone is running on http only or something like this.

  • Check your endpoint for Keystone
  • Check your ironic.conf => identity_uri = $keystone_endpoint

Cheers Heiko

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-01-19 05:58:46 -0500

Seen: 651 times

Last updated: Jan 29 '15