Ask Your Question
0

#RDO 2 node packstack puupet fails on netron install on compute node with error

asked 2015-01-18 21:23:09 -0500

woolright gravatar image

updated 2015-01-19 00:06:12 -0500

dbaxps gravatar image

Hi I have followed the following http://cloudssky.com/en/blog/RDO-Open... and it fails when puppet is trying to setup neutron on the compute node. Ant and all help greatly appreciated this i am very green with openstack so this is my first stack attempt

ERROR : Error appeared during Puppet run: 10.0.0.13_neutron.pp Error: Local ip for ovs agent must be set when tunneling is enabled at /var/tmp/packstack/3e77edc38c3d4f038847fe9a18fb8eac/modules/neutron/manifests/agents/ml2/ovs.pp:113 on node rev-stack-comp1

Have searched on forums and googled everything but could find nothing of relevance or helpfull anybody had the same issue and resolved ?

Details both nodes running FC20

controller 10.0.0.11 p6p1 and 10.12.13.10 in IF enp4s1
Compute 10.0.0.13 em1 and 10.12.13.20 on IF em2

CONFIG_NEUTRON_KS_PW=808e36e154bd4cee
CONFIG_NEUTRON_DB_PW=0e2b927a21b44737
CONFIG_NEUTRON_L3_EXT_BRIDGE=br-ex
CONFIG_NEUTRON_L2_PLUGIN=ml2
CONFIG_NEUTRON_METADATA_PW=a965cd23ed2f4502
CONFIG_LBAAS_INSTALL=n
CONFIG_NEUTRON_METERING_AGENT_INSTALL=n
CONFIG_NEUTRON_FWAAS=n
CONFIG_NEUTRON_ML2_TYPE_DRIVERS=vxlan
CONFIG_NEUTRON_ML2_TENANT_NETWORK_TYPES=vxlan
CONFIG_NEUTRON_ML2_MECHANISM_DRIVERS=openvswitch
CONFIG_NEUTRON_ML2_FLAT_NETWORKS=*
CONFIG_NEUTRON_ML2_VLAN_RANGES=
CONFIG_NEUTRON_ML2_TUNNEL_ID_RANGES=1001:2000
CONFIG_NEUTRON_ML2_VXLAN_GROUP=239.1.1.2
CONFIG_NEUTRON_ML2_VNI_RANGES=1001:2000
CONFIG_NEUTRON_L2_AGENT=openvswitch
CONFIG_NEUTRON_LB_TENANT_NETWORK_TYPE=local
CONFIG_NEUTRON_LB_VLAN_RANGES=
CONFIG_NEUTRON_LB_INTERFACE_MAPPINGS=
CONFIG_NEUTRON_OVS_TENANT_NETWORK_TYPE=vxlan
CONFIG_NEUTRON_OVS_VLAN_RANGES=
CONFIG_NEUTRON_OVS_BRIDGE_MAPPINGS=physnet1:br-ex
CONFIG_NEUTRON_OVS_BRIDGE_IFACES=
CONFIG_NEUTRON_OVS_TUNNEL_RANGES=1001:2000
CONFIG_NEUTRON_OVS_TUNNEL_IF=enp4s1
CONFIG_NEUTRON_OVS_VXLAN_UDP_PORT=4789
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-01-19 00:20:46 -0500

dbaxps gravatar image

updated 2015-01-19 06:56:26 -0500

Please, view : https://openstack.redhat.com/forum/di...
For eth1 && eht0 interfaces on CentOS 6.X
Larsks wrote:

Interface eth1 (your CONFIG_NEUTRON_OVS_TUNNEL_IF) must be UP and must have an address assigned. In general this means you will need to create and/or edit /etc/sysconfig/network-scripts/ifcfg-eth1 appropriately, and then run ifup eth1.
If you think your interface is already correctly configured, please post the contents of ifcfg-eth1 as well as the output of ip addr.

It's exactly your case, the only one issue different CONFIG_NEUTRON_OVS_TUNNEL_IF Ethernet names on different boxes. Regarding this issue view : -
http://www.freedesktop.org/wiki/Softw...

Answer-file has following entries :-

CONFIG_NOVA_NETWORK_PUBIF=enp2s0
CONFIG_NOVA_NETWORK_PRIVIF=enp5s1
CONFIG_NOVA_COMPUTE_PRIVIF=enp5s1
CONFIG_NEUTRON_OVS_TUNNEL_IF=enp5s1

and packstack doing MultiNode deployment expects this Ethernet names to be the same on all Fedora Nodes on landscape ( it's better when this name are native ,e.g. been set up during Fedora system installs at least via my experience )
You may follow also another approach setting up TwoNode RDO Juno Cluster : http://bderzhavets.blogspot.com/2014/...
However, matching Ethernet names on Controller&&Network and Compute Node will still be required by packstack working via answer-file.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-01-18 21:23:09 -0500

Seen: 1,231 times

Last updated: Jan 19 '15