Ask Your Question
0

Poor Network Connection issue with Windows Instance

asked 2015-01-17 04:39:15 -0500

rahulrajvn gravatar image

updated 2015-01-20 15:40:39 -0500

I was able to create windows instance and get it working, but the rdp connection to the instance gets disconencted once in while. I had similar issues in linux and it was resolved by turning off tso,gso and gro in the nic cards.

Has any one faced such issue , I have tried tweaking off checksum in windows nic but it was not worth it. Please update me if there is an thing I can try.

Update: I have also tried updating the VirtIO Drives

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-01-20 21:56:38 -0500

js.mouret gravatar image

You can also try to adjust the MTU. Windows doesn't apply the MTU advertised by the DHCP. If you are running with neutron and GRE tunnels, it should be 1454 instead of 1500.

edit flag offensive delete link more

Comments

And also try to turn off gro by ethtool -K INTERFACE_NAME gro off. Replace INTERFACE_NAME with adapter, you are using with Openstack

Khayam gravatar imageKhayam ( 2015-01-20 23:23:17 -0500 )edit
0

answered 2015-01-20 16:39:14 -0500

jpf gravatar image

You may want to check your RDP keep alive settings: http://nmsiam.blogspot.com/2013/01/remote-desktop-session-timeouts.html (http://nmsiam.blogspot.com/2013/01/re...)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-01-17 04:39:15 -0500

Seen: 678 times

Last updated: Jan 20 '15